compat: fix defines for RHEL by adding RHEL to string
authorAndy Gospodarek <andy@greyhouse.net>
Tue, 14 Aug 2012 18:59:46 +0000 (14:59 -0400)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Tue, 14 Aug 2012 23:07:42 +0000 (16:07 -0700)
The .config file contains 'CONFIG_COMPAT_6_1,' when it should contain,
'CONFIG_COMPAT_RHEL_6_1.'  This fixes that by adding the 'RHEL' in the
proper spot.

Signed-off-by: Andy Gospodarek <andy@greyhouse.net>
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
scripts/gen-compat-config.sh

index a3ebf082efc1208086cf75c28d83e71c7eb63e52..54f053d4192d59d6710506fa19d9a9770d916751 100755 (executable)
@@ -50,8 +50,8 @@ RHEL_MAJOR=$(grep ^RHEL_MAJOR ${KLIB_BUILD}/Makefile | sed -n 's/.*= *\(.*\)/\1/
 if [[ ! -z ${RHEL_MAJOR} ]]; then
        RHEL_MINOR=$(grep ^RHEL_MINOR ${KLIB_BUILD}/Makefile | sed -n 's/.*= *\(.*\)/\1/p')
        for i in $(seq 0 ${RHEL_MINOR}); do
-               eval CONFIG_COMPAT_${RHEL_MAJOR}_${i}=y
-               echo "export CONFIG_COMPAT_${RHEL_MAJOR}_${i}=y"
+               eval CONFIG_COMPAT_RHEL_${RHEL_MAJOR}_${i}=y
+               echo "export CONFIG_COMPAT_RHEL_${RHEL_MAJOR}_${i}=y"
        done
 fi