gupnp-vala: add package
authorFlorian Fainelli <florian@openwrt.org>
Wed, 5 Dec 2012 17:31:31 +0000 (17:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 5 Dec 2012 17:31:31 +0000 (17:31 +0000)
Signed-off-by: Andy Leiserson <andy@leiserson.org>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34525

libs/gupnp-vala/Makefile [new file with mode: 0644]
libs/gupnp-vala/patches/010-no-tests.patch [new file with mode: 0644]

diff --git a/libs/gupnp-vala/Makefile b/libs/gupnp-vala/Makefile
new file mode 100644 (file)
index 0000000..d980a3e
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gupnp-vala
+PKG_VERSION:=0.10.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/gupnp-vala/0.10/
+PKG_MD5SUM:=
+
+PKG_BUILD_DEPENDS:=vala/host libgssdp libgupnp libgupnp-av libgupnp-dlna
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/libgupnp-vala
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=GUPnP Vala bindings
+  URL:=http://live.gnome.org/GUPnP
+endef
+
+define Package/libgupnp-vala/description
+Vala bindings for GUPnP
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DIR) $(1)/usr/share/vala/vapi
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/vala/vapi/*.{vapi,deps} \
+               $(1)/usr/share/vala/vapi
+endef
+
+$(eval $(call BuildPackage,libgupnp-vala))
diff --git a/libs/gupnp-vala/patches/010-no-tests.patch b/libs/gupnp-vala/patches/010-no-tests.patch
new file mode 100644 (file)
index 0000000..faf919e
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,7 +2,7 @@
+ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+-SUBDIRS = . tests
++SUBDIRS = .
+ pkgconfig_DATA= gupnp-vala-1.0.pc
+ pkgconfigdir = $(libdir)/pkgconfig