ucode: update to Git HEAD (2025-03-06)
authorFelix Fietkau <nbd@nbd.name>
Fri, 7 Mar 2025 15:17:59 +0000 (16:17 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 9 Mar 2025 15:44:52 +0000 (16:44 +0100)
9d94d54ed1a3 uci: implement cursor.list_append() and cursor.list_remove()
a5a299075f37 zlib: rework code logic
ee6a6c3ca579 zlib: deduplicate code
d20f7bb87d47 zlib: add stream-oriented deflate operations
0255af462be3 zlib: add stream-oriented inflate operations
9260bd5354bf WIP: lib: support map() over objects
60f05ac60bfe docs: cover switch statement in syntax article
338aa2ebf00e docs: add article with array specific information
df5a79a04b17 uci: link save() and commit() functions in cursor class description
03fb60d0e4b3 docs: add detailed documentation article for dictionaries
8e122f16327c ubus: add support for calling system objects
21a615c84367 socket: add reuseaddr argument for socket.listen()
e04908ef57e7 uci: add support for altering the override config directory
9dbace122d7e socket: add missing documentation for socket.listen() reuseaddr

Fixes: https://github.com/jow-/ucode/issues/279
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/utils/ucode/Makefile

index ef253f897edd58aba5c56cdac63908beb8b262d3..d8a43087714adde642dbe797f27fd82ed0923be1 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2025-02-10
-PKG_SOURCE_VERSION:=a8a11aea0c093d669bb3c45f604dab3c291c8d25
-PKG_MIRROR_HASH:=e08c36818a72eb2953b56300207d1fb7a852ada33df36f63a495ad35ca21b88e
+PKG_SOURCE_DATE:=2025-03-06
+PKG_SOURCE_VERSION:=1707cba0c618f82f82566b025fbe73e1ba176eaf
+PKG_MIRROR_HASH:=a99042f228b0ceae3de09b12cfe332d6f98d5ce42ea2b212c7e8645fd79f34c8
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC