[packages] i2c-tools: update to 3.0.3, refresh patches
authorStephen Walker <stephendwalker@gmail.com>
Wed, 5 Jan 2011 21:27:53 +0000 (21:27 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Wed, 5 Jan 2011 21:27:53 +0000 (21:27 +0000)
SVN-Revision: 24912

utils/i2c-tools/Makefile
utils/i2c-tools/patches/100-linux_include.patch

index e3f2394141e4e9489ae65e90a81e1b49edf46c73..3452bee6656c599a2eaed5cc18cdf9b182a27388 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=i2c-tools
-PKG_VERSION:=3.0.2
-PKG_RELEASE:=2
+PKG_VERSION:=3.0.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://dl.lm-sensors.org/i2c-tools/releases/
-PKG_MD5SUM:=b546345ac19db56719dea6b8199f11e0
+PKG_SOURCE_URL:=http://dl.lm-sensors.org/i2c-tools/releases
+PKG_MD5SUM:=511376eed04455cdb277ef19c5f73bb4
 
 PKG_BUILD_DEPENDS:=python
 
@@ -49,8 +49,8 @@ define Package/i2c-tools/description
 endef
 
 define Package/python-smbus/description
- This package contains an heterogeneous set of I2C tools for Linux. 
+ This package contains an heterogeneous set of I2C tools for Linux.
+
  This package contain the python bindings for Linux SMBus access through i2c-dev.
 endef
 
index 4491b262ff029f975c615dd741874736ac7c7626..addfc5bc3b0c783e77cf4e4d18aa0ccb87302b48 100644 (file)
@@ -1,7 +1,5 @@
-Index: i2c-tools-3.0.2/py-smbus/smbusmodule.c
-===================================================================
---- i2c-tools-3.0.2.orig/py-smbus/smbusmodule.c        2010-07-23 23:09:16.000000000 +0200
-+++ i2c-tools-3.0.2/py-smbus/smbusmodule.c     2010-07-23 23:09:29.000000000 +0200
+--- a/py-smbus/smbusmodule.c
++++ b/py-smbus/smbusmodule.c
 @@ -21,6 +21,7 @@
  #include <stdlib.h>
  #include <stdio.h>
@@ -10,4 +8,3 @@ Index: i2c-tools-3.0.2/py-smbus/smbusmodule.c
  #include <linux/i2c-dev.h>
  
  /*
-