ramips: gpio: remove header "gpio.h"
authorShiji Yang <yangshiji66@qq.com>
Fri, 28 Jun 2024 07:36:13 +0000 (15:36 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 4 Jul 2024 20:20:47 +0000 (22:20 +0200)
There are no source files using it.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
target/linux/ramips/patches-6.6/802-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch

index 53c28acaf0e200642c08bc57913539e8ceeed0ab..a79bb7e5bfa388ee670665c2f41fe75c8173e376 100644 (file)
@@ -7,41 +7,12 @@ RT2880, RT305x, rt3352, rt3662, rt3883, rt5350 and mt7620 work.
 
 Signed-off-by: John Crispin <blogic@openwrt.org>
 ---
- arch/mips/include/asm/mach-ralink/gpio.h |  24 ++
- drivers/gpio/Kconfig                     |   6 +
- drivers/gpio/Makefile                    |   1 +
- drivers/gpio/gpio-ralink.c               | 336 +++++++++++++++++++++++
- 4 files changed, 367 insertions(+)
- create mode 100644 arch/mips/include/asm/mach-ralink/gpio.h
+ drivers/gpio/Kconfig       |   6 +
+ drivers/gpio/Makefile      |   1 +
+ drivers/gpio/gpio-ralink.c | 336 +++++++++++++++++++++++++++++++++++++
+ 3 files changed, 343 insertions(+)
  create mode 100644 drivers/gpio/gpio-ralink.c
 
---- /dev/null
-+++ b/arch/mips/include/asm/mach-ralink/gpio.h
-@@ -0,0 +1,24 @@
-+/*
-+ *  Ralink SoC GPIO API support
-+ *
-+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
-+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ *  This program is free software; you can redistribute it and/or modify it
-+ *  under the terms of the GNU General Public License version 2 as published
-+ *  by the Free Software Foundation.
-+ *
-+ */
-+
-+#ifndef __ASM_MACH_RALINK_GPIO_H
-+#define __ASM_MACH_RALINK_GPIO_H
-+
-+#define ARCH_NR_GPIOS 128
-+#include <asm-generic/gpio.h>
-+
-+#define gpio_get_value        __gpio_get_value
-+#define gpio_set_value        __gpio_set_value
-+#define gpio_cansleep __gpio_cansleep
-+#define gpio_to_irq   __gpio_to_irq
-+
-+#endif /* __ASM_MACH_RALINK_GPIO_H */
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
 @@ -594,6 +594,12 @@ config GPIO_SNPS_CREG