usability and stability patch from package maintainer Johannes 5 Joemann, thx a lt
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 3 Aug 2005 11:13:00 +0000 (11:13 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 3 Aug 2005 11:13:00 +0000 (11:13 +0000)
SVN-Revision: 1580

openwrt/package/Makefile
openwrt/package/quagga/Config.in
openwrt/package/quagga/Makefile
openwrt/package/quagga/ipkg/quagga-bgpd.control
openwrt/package/quagga/ipkg/quagga-ospf6d.control
openwrt/package/quagga/ipkg/quagga-ospfd.control
openwrt/package/quagga/ipkg/quagga-ripd.control
openwrt/package/quagga/ipkg/quagga-ripngd.control
openwrt/package/quagga/patches/quagga-cross.patch

index 09e05e6dbdb79c58654c9eed3173ad06a47d4105..359dcdb59ab68a92ba337d2360f91b02c9a3f80f 100644 (file)
@@ -155,6 +155,7 @@ openswan-compile: gmp-compile
 osiris-compile: openssl-compile
 portmap-compile: tcp_wrappers-compile
 postgresql-compile: zlib-compile
+quagga-compile: readline-compile ncurses-compile
 rsync-compile: popt-compile
 screen-compile: ncurses-compile
 siproxd-compile: libosip2-compile
index 87233d11038d21c43c961c003388d5057b2d5028..7e893e2053a293c0e339bdc2810e7157a0329cb8 100644 (file)
@@ -10,42 +10,31 @@ config BR2_PACKAGE_QUAGGA
          OSPFv3, BGP-4, and BGP-4+
          
          http://www.quagga.net/
-         
 
 config BR2_PACKAGE_QUAGGA_BGPD
        depends BR2_PACKAGE_QUAGGA
-       prompt "...-bgpd - BGPv4, BGPv4\+, BGPv4\- routing engine"
+       prompt "...-bgpd - BGPv4, BGPv4+, BGPv4- routing engine"
        tristate
        default m if CONFIG_DEVEL
        help
-         A BGPv4, BGPv4\+, BGPv4\- routing engine for use with Quagga routing
+         A BGPv4, BGPv4+, BGPv4- routing engine for use with Quagga routing
          software.
 
-config BR2_PACKAGE_LIBOSPF
-       depends BR2_PACKAGE_QUAGGA
-       prompt "libospf - OSPF support library"
-       tristate
-       default m if CONFIG_DEVEL
-       help
-         An OSPFv2 routing engine for use with Quagga routing software.
-
 config BR2_PACKAGE_QUAGGA_OSPFD
        depends BR2_PACKAGE_QUAGGA
        prompt "...-ospfd - OSPFv2 routing engine"
-       select BR2_PACKAGE_LIBOSPF
        tristate
        default m if CONFIG_DEVEL
        help
-         An OSPFv2 routing engine for use with Quagga routing software.
+         An OSPFv2 (IPv4) routing engine for use with Quagga routing software.
 
 config BR2_PACKAGE_QUAGGA_OSPF6D
        depends BR2_PACKAGE_QUAGGA
        prompt "...-ospf6d - OSPFv3 routing engine"
-       select BR2_PACKAGE_LIBOSPF
        tristate
        default m if CONFIG_DEVEL
        help
-         An OSPFv3 routing engine for use with Quagga routing software.
+         An OSPFv3 (IPv6) routing engine for use with Quagga routing software.
 
 config BR2_PACKAGE_QUAGGA_RIPD
        depends BR2_PACKAGE_QUAGGA
@@ -53,22 +42,25 @@ config BR2_PACKAGE_QUAGGA_RIPD
        tristate
        default m if CONFIG_DEVEL
        help
-         A RIP routing engine for use with Quagga routing software.
+         A RIP (IPv4) routing engine for use with Quagga routing software.
 
-config BR2_PACKAGE_QUAGGA_RIPD
+config BR2_PACKAGE_QUAGGA_RIPNGD
        depends BR2_PACKAGE_QUAGGA
        prompt "...-ripngd - RIPNG routing engine"
        tristate
        default m if CONFIG_DEVEL
        help
-         A RIPNG routing engine for use with Quagga routing software.
+         A RIPNG (IPv6) routing engine for use with Quagga routing software.
 
-config BR2_PACKAGE_QUAGGA_ZEBRA
+config BR2_PACKAGE_QUAGGA_VTYSH
        depends BR2_PACKAGE_QUAGGA
-       prompt "...-zebra - Routing manager"
+       select BR2_PACKAGE_LIBREADLINE
+       select BR2_PACKAGE_LIBNCURSES
+       prompt "...-vtysh - integrated shell for Quagga routing software"
        tristate
        default m if CONFIG_DEVEL
        help
-         A routing manager for use with associated Quagga components.
+         vtysh lets you interact with all the Quagga routing daemons
+         at once in an integrated shell.
 
 endmenu
index fca54ecb9b69347a9f5c0379025e2de0ce8a3e2d..32d6d6603e41f1a6448a332c99696ef4c46e8c32 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quagga
-PKG_VERSION:=0.98.3
+PKG_VERSION:=0.98.4
 PKG_RELEASE:=1
-PKG_MD5SUM:=68be5e911e4d604c0f5959338263356e
+PKG_MD5SUM:=c68e409931449afc5730289d3105f502
 
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
                 http://www.de.quagga.net/download/ \
@@ -21,17 +21,17 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,QUAGGA,quagga,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_BGPD,quagga-bgpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,LIBOSPF,libospf,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_OSPFD,quagga-ospfd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_OSPF6D,quagga-ospf6d,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_RIPD,quagga-ripd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_RIPNGD,quagga-ripngd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,QUAGGA_ZEBRA,quagga-zebra,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,QUAGGA_VTYSH,quagga-vtysh,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
@@ -48,19 +48,18 @@ $(PKG_BUILD_DIR)/.configured:
                --infodir=/usr/share/info \
                --libdir=/usr/lib \
                --libexecdir=/usr/lib \
-               --localstatedir=/var \
+               --localstatedir=/var/run/quagga \
                --mandir=/usr/share/man \
                --sbindir=/usr/sbin \
-               --sysconfdir=/etc \
+               --sysconfdir=/etc/quagga \
                $(DISABLE_NLS) \
                $(DISABLE_LARGEFILE) \
                --enable-shared \
                --disable-static \
                --enable-ipv6 \
-               --disable-vtysh \
+               --enable-vtysh \
                --enable-user=quagga \
                --enable-group=quagga \
-               --sysconfdir=/etc/quagga \
        );
        touch $@
 
@@ -73,6 +72,15 @@ $(PKG_BUILD_DIR)/.built:
 $(IPKG_QUAGGA):
        install -d -m0755 $(IDIR_QUAGGA)/usr/lib
        cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libzebra.so.* $(IDIR_QUAGGA)/usr/lib/
+       install -d -m0755 $(IDIR_QUAGGA)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/zebra $(IDIR_QUAGGA)/usr/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/watchquagga $(IDIR_QUAGGA)/usr/sbin/
+       # avoid /etc being set to 0750
+       install -d -m0755 $(IDIR_QUAGGA)/etc/quagga/
+       chmod 0750 $(IDIR_QUAGGA)/etc/quagga/
+       install -d -m0755 $(IDIR_QUAGGA)/etc/init.d/
+       install -m0755 ./files/quagga.init $(IDIR_QUAGGA)/etc/init.d/quagga
+       ln -sf quagga $(IDIR_QUAGGA)/etc/init.d/S49quagga
        $(RSTRIP) $(IDIR_QUAGGA)
        $(IPKG_BUILD) $(IDIR_QUAGGA) $(PACKAGE_DIR)
 
@@ -82,13 +90,9 @@ $(IPKG_QUAGGA_BGPD):
        $(RSTRIP) $(IDIR_QUAGGA_BGPD)
        $(IPKG_BUILD) $(IDIR_QUAGGA_BGPD) $(PACKAGE_DIR)
 
-$(IPKG_LIBOSPF):
-       install -d -m0755 $(IDIR_LIBOSPF)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libospf.so.* $(IDIR_LIBOSPF)/usr/lib/
-       $(RSTRIP) $(IDIR_LIBOSPF)
-       $(IPKG_BUILD) $(IDIR_LIBOSPF) $(PACKAGE_DIR)
-
 $(IPKG_QUAGGA_OSPFD):
+       install -d -m0755 $(IDIR_QUAGGA_OSPFD)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libospf.so.* $(IDIR_QUAGGA_OSPFD)/usr/lib/
        install -d -m0755 $(IDIR_QUAGGA_OSPFD)/usr/sbin
        cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/ospfd $(IDIR_QUAGGA_OSPFD)/usr/sbin/
        $(RSTRIP) $(IDIR_QUAGGA_OSPFD)
@@ -96,7 +100,7 @@ $(IPKG_QUAGGA_OSPFD):
 
 $(IPKG_QUAGGA_OSPF6D):
        install -d -m0755 $(IDIR_QUAGGA_OSPF6D)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/ospfd $(IDIR_QUAGGA_OSPF6D)/usr/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/ospf6d $(IDIR_QUAGGA_OSPF6D)/usr/sbin/
        $(RSTRIP) $(IDIR_QUAGGA_OSPF6D)
        $(IPKG_BUILD) $(IDIR_QUAGGA_OSPF6D) $(PACKAGE_DIR)
 
@@ -112,9 +116,8 @@ $(IPKG_QUAGGA_RIPNGD):
        $(RSTRIP) $(IDIR_QUAGGA_RIPNGD)
        $(IPKG_BUILD) $(IDIR_QUAGGA_RIPNGD) $(PACKAGE_DIR)
 
-$(IPKG_QUAGGA_ZEBRA):
-       install -d -m0755 $(IDIR_QUAGGA_ZEBRA)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/zebra $(IDIR_QUAGGA_ZEBRA)/usr/sbin/
-       $(RSTRIP) $(IDIR_QUAGGA_ZEBRA)
-       $(IPKG_BUILD) $(IDIR_QUAGGA_ZEBRA) $(PACKAGE_DIR)
-
+$(IPKG_QUAGGA_VTYSH):
+       install -d -m0755 $(IDIR_QUAGGA_VTYSH)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/vtysh $(IDIR_QUAGGA_VTYSH)/usr/bin/
+       $(RSTRIP) $(IDIR_QUAGGA_VTYSH)
+       $(IPKG_BUILD) $(IDIR_QUAGGA_VTYSH) $(PACKAGE_DIR)
index 0c2c401c00cfce9101bbf1406c324d8263fb9e48..dab6c33f1cab74a42c474bfacca4bff1c3e48728 100644 (file)
@@ -3,5 +3,6 @@ Priority: optional
 Section: net
 Maintainer: Johannes 5 Joemann <joemann@beefree.free.de>
 Source: buildroot internal
-Description: A BGPv4, BGPv4\+, BGPv4\- routing engine for use
- with Quagga routing software
+Depends: quagga
+Description: A BGPv4, BGPv4+, BGPv4- routing engine for use with Quagga
+ routing software
index 6d20fd88962c1a2c09cf69fcfc1579ddd6e57f83..65e324b6ae73df6e819306256d6206555363e66a 100644 (file)
@@ -3,6 +3,6 @@ Priority: optional
 Section: net
 Maintainer: Johannes 5 Joemann <joemann@beefree.free.de>
 Source: buildroot internal
-Depends: libospf
-Description: An OSPFv3 routing engine for use
with Quagga routing software
+Depends: quagga
+Description: An OSPFv3 routing engine for use with Quagga
+ routing software
index be9ca20a050e769d1b14b0d5813f70cb7887720f..9ebca493a9854ad6a9dbfbe7f16faa1214273784 100644 (file)
@@ -3,6 +3,6 @@ Priority: optional
 Section: net
 Maintainer: Johannes 5 Joemann <joemann@beefree.free.de>
 Source: buildroot internal
-Depends: libospf
-Description: An OSPFv2 routing engine for use
with Quagga routing software
+Depends: quagga
+Description: An OSPFv2 routing engine for use with Quagga
+ routing software
index b9362d907a579d3b7da99d183a765b90b5c7a878..adee8b5e4c17dff0fa04465ea26f848d388f4771 100644 (file)
@@ -3,5 +3,6 @@ Priority: optional
 Section: net
 Maintainer: Johannes 5 Joemann <joemann@beefree.free.de>
 Source: buildroot internal
-Description: A RIP routing engine for use
- with Quagga routing software
+Depends: quagga
+Description: A RIP routing engine for use with Quagga
+ routing software
index 8c6e5b59d2dbd8f1a103b9f21178a93f2d379853..7fc15f285d08bdb8449939a33471e6fb9aa1e441 100644 (file)
@@ -3,5 +3,6 @@ Priority: optional
 Section: net
 Maintainer: Johannes 5 Joemann <joemann@beefree.free.de>
 Source: buildroot internal
-Description: A RIPNG routing engine for use
- with Quagga routing software
+Depends: quagga
+Description: A RIPNG routing engine for use with Quagga
+ routing software
index 69b83283bfce7be3265861b1d239bab603bc0a51..5b8276bcc12f09ea9bbef5a77f24d514b8b0b439 100644 (file)
@@ -1,17 +1,14 @@
---- quagga-0.98.2/configure.orig       Thu Feb  3 17:39:29 2005
-+++ quagga-0.98.2/configure    Sat Feb 12 06:47:14 2005
-@@ -12491,72 +12491,6 @@
+--- quagga-0.98.4/configure.orig       Mon Jun 27 19:05:31 2005
++++ quagga-0.98.4/configure    Mon Jul 11 20:32:07 2005
+@@ -12623,69 +12623,6 @@
  
  
  
 -echo "$as_me:$LINENO: checking for broken CMSG_FIRSTHDR" >&5
 -echo $ECHO_N "checking for broken CMSG_FIRSTHDR... $ECHO_C" >&6
 -if test "$cross_compiling" = yes; then
--  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&5
--echo "$as_me: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&2;}
--   { (exit 1); exit 1; }; }
+-  echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
 -else
 -  cat >conftest.$ac_ext <<_ACEOF
 -/* confdefs.h.  */
@@ -73,7 +70,7 @@
  echo "$as_me:$LINENO: checking route read method check" >&5
  echo $ECHO_N "checking route read method check... $ECHO_C" >&6
  if test "${zebra_rtread+set}" = set; then
-@@ -12654,10 +12588,7 @@
+@@ -12783,10 +12720,7 @@
  if test "${zebra_ipforward_path+set}" = set; then
    echo $ECHO_N "(cached) $ECHO_C" >&6
  else