projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f20b6c3
)
openssl: don't fail with empty TARGET_LDFLAGS
author
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 18 Jan 2012 03:54:09 +0000
(
03:54
+0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 18 Jan 2012 03:54:09 +0000
(
03:54
+0000)
SVN-Revision: 29770
package/openssl/Makefile
patch
|
blob
|
history
diff --git
a/package/openssl/Makefile
b/package/openssl/Makefile
index cc253d686de2947d087fe8840e416a2e8fc46de7..48e8a427f6983a7f53b86c0917135414f1c2b1ce 100644
(file)
--- a/
package/openssl/Makefile
+++ b/
package/openssl/Makefile
@@
-142,7
+142,7
@@
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(
SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(
if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc)
endef
define Package/libopenssl/install