dropbear: bump to 2024.86
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Nov 2024 21:32:03 +0000 (22:32 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 28 Nov 2024 18:49:19 +0000 (18:49 +0000)
- update dropbear to latest stable 2024.86;
  for the changes see https://matt.ucc.asn.au/dropbear/CHANGES

Link: https://github.com/openwrt/openwrt/pull/17053
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit a9d3c5b4c9bf910d4b3b42109161b1f6526b76eb)
Link: https://github.com/openwrt/openwrt/pull/17097
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/network/services/dropbear/Makefile
package/network/services/dropbear/patches/110-change_user.patch

index 1918e7dec6d6ce61efc07e5c068df69738bdd2a0..e13b6c2145b716b5cb5d926e5e79f07cba3ca699 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=2024.85
-PKG_RELEASE:=2
+PKG_VERSION:=2024.86
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        https://matt.ucc.asn.au/dropbear/releases/ \
        https://dropbear.nl/mirror/releases/
-PKG_HASH:=86b036c433a69d89ce51ebae335d65c47738ccf90d13e5eb0fea832e556da502
+PKG_HASH:=e78936dffc395f2e0db099321d6be659190966b99712b55c530dd0a1822e0a5e
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
index 9cb073cf940d46779ef99fc98ad891d6b82fbff5..9ef8f0cfbc49814b1b6b5cb287d9cfba8f4a7e74 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/svr-chansession.c
 +++ b/src/svr-chansession.c
-@@ -987,12 +987,12 @@ static void execchild(const void *user_d
+@@ -984,12 +984,12 @@ static void execchild(const void *user_d
        /* We can only change uid/gid as root ... */
        if (getuid() == 0) {