projects
/
openwrt
/
staging
/
ansuel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cb9c37a
)
base-files: revert dhcp state information on ifdown and restore pre-r19530 behaviour...
author
Jo-Philipp Wich
<jow@openwrt.org>
Fri, 12 Feb 2010 02:06:57 +0000
(
02:06
+0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Fri, 12 Feb 2010 02:06:57 +0000
(
02:06
+0000)
SVN-Revision: 19597
package/base-files/Makefile
patch
|
blob
|
history
package/base-files/files/lib/network/config.sh
patch
|
blob
|
history
package/base-files/files/usr/share/udhcpc/default.script
patch
|
blob
|
history
diff --git
a/package/base-files/Makefile
b/package/base-files/Makefile
index fa0711fe2ac5dc8fd0268d0c3ab53988a3d09d5c..5cd87a66f5069843c8bb2c26db44cc3761d2abca 100644
(file)
--- a/
package/base-files/Makefile
+++ b/
package/base-files/Makefile
@@
-10,7
+10,7
@@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=3
8
+PKG_RELEASE:=3
9
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git
a/package/base-files/files/lib/network/config.sh
b/package/base-files/files/lib/network/config.sh
index 12b08a29ff49bb2fa7a5ca2a9145d4c1f45d0ea6..b7d7b259a94d21f0db272c1d530fc47b2e7616c3 100755
(executable)
--- a/
package/base-files/files/lib/network/config.sh
+++ b/
package/base-files/files/lib/network/config.sh
@@
-327,6
+327,11
@@
setup_interface() {
}
}
+stop_interface_dhcp() {
+ local config="$1"
+ uci -P /var/state revert "network.$config"
+}
+
unbridge() {
local dev="$1"
local brdev
diff --git
a/package/base-files/files/usr/share/udhcpc/default.script
b/package/base-files/files/usr/share/udhcpc/default.script
index f704a7bf293c20ef2553261b1ca943fa9f34732f..b32b2c9f256e5c941f2fe0e5fd0f98399ded6dad 100755
(executable)
--- a/
package/base-files/files/usr/share/udhcpc/default.script
+++ b/
package/base-files/files/usr/share/udhcpc/default.script
@@
-31,8
+31,7
@@
setup_interface () {
config_get old_subnet "$ifc" netmask
}
- [ "$1" = "ifup" ] \
- || [ "$ip" != "$old_ip" ] \
+ [ "$ip" != "$old_ip" ] \
|| [ "${broadcast:-+}" != "$old_broadcast" ] \
|| [ "${subnet:-255.255.255.0}" != "$old_subnet" ] && {
echo "udhcpc: ifconfig $interface $ip netmask ${subnet:-255.255.255.0} broadcast ${broadcast:-+}"