kernel: kmod-btmtk: Extract btmtk.ko into own package
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 25 Feb 2025 20:15:19 +0000 (21:15 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 26 Feb 2025 22:31:36 +0000 (23:31 +0100)
btmtk.ko is used by btusb.ko and btmtkuart.ko, add it into an own
package and make both packages depend on it.

Fixes: 1c42a0be3619 ("kernel: modules: bluetooth: separating UART and USB drivers")
Link: https://github.com/openwrt/openwrt/pull/18110
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/bluetooth.mk
target/linux/mediatek/modules.mk

index a498c31e0b3b7341ccd940648eadf1fba10cf343..b4163eb950a457bdc29d874181d41da397510c84 100644 (file)
@@ -60,7 +60,7 @@ $(eval $(call KernelPackage,hci-uart))
 define KernelPackage/btusb
   SUBMENU:=$(BLUETOOTH_MENU)
   TITLE:=Bluetooth HCI USB support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-bluetooth
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-bluetooth +kmod-btmtk
   KCONFIG:= \
        CONFIG_BT_HCIBTUSB \
        CONFIG_BT_HCIBTUSB_BCM=n \
@@ -69,8 +69,7 @@ define KernelPackage/btusb
   FILES:= \
        $(LINUX_DIR)/drivers/bluetooth/btusb.ko \
        $(LINUX_DIR)/drivers/bluetooth/btintel.ko \
-       $(LINUX_DIR)/drivers/bluetooth/btrtl.ko \
-       $(LINUX_DIR)/drivers/bluetooth/btmtk.ko
+       $(LINUX_DIR)/drivers/bluetooth/btrtl.ko
   AUTOLOAD:=$(call AutoProbe,btusb)
 endef
 
@@ -81,6 +80,18 @@ endef
 $(eval $(call KernelPackage,btusb))
 
 
+define KernelPackage/btmtk
+  SUBMENU:=$(BLUETOOTH_MENU)
+  TITLE:=MTK Bluetooth support
+  HIDDEN:=1
+  DEPENDS:=+kmod-bluetooth
+  KCONFIG:=CONFIG_BT_MTK
+  FILES:=$(LINUX_DIR)/drivers/bluetooth/btmtk.ko
+endef
+
+$(eval $(call KernelPackage,btmtk))
+
+
 define KernelPackage/ath3k
   SUBMENU:=$(BLUETOOTH_MENU)
   TITLE:=ATH3K Kernel Module support
index 84801237259017e54cfa824e5d205b3dd0e87028..ade8d60ab385b9c696a448428f8138bf87f69f9a 100644 (file)
@@ -18,7 +18,7 @@ $(eval $(call KernelPackage,ata-ahci-mtk))
 define KernelPackage/btmtkuart
   SUBMENU:=Other modules
   TITLE:=MediaTek HCI UART driver
-  DEPENDS:=@TARGET_mediatek_mt7622 +kmod-bluetooth +mt7622bt-firmware
+  DEPENDS:=@TARGET_mediatek_mt7622 +kmod-bluetooth +kmod-btmtk +mt7622bt-firmware
   KCONFIG:=CONFIG_BT_MTKUART
   FILES:= \
        $(LINUX_DIR)/drivers/bluetooth/btmtkuart.ko