[packages] net-snmp: fix snmpd.init generating wrong 'exec' configuration (closes...
authorNicolas Thill <nico@openwrt.org>
Tue, 21 Apr 2009 22:58:42 +0000 (22:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 21 Apr 2009 22:58:42 +0000 (22:58 +0000)
SVN-Revision: 15334

libs/net-snmp/Makefile
libs/net-snmp/files/snmpd.init

index a8ab3c11f88d2e24e170c534548925e8ca3e4164..3c174fa6cd0cd3129b4753bbee65ac162355e511 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-snmp
 PKG_VERSION:=5.1.2
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/net-snmp
index f48e503aee3b4e7e6936ab4ca48ded517f555fe5..065ffb3c445a7453c3533bb5902e76f2a1a0e918 100644 (file)
@@ -98,7 +98,7 @@ snmpd_exec_add() {
        [ -n "$prog" ] || return 0
        config_get args "$cfg" args
        config_get miboid "$cfg" miboid
-       echo "exec $cfg $miboid $prog $args" >> $RUN_C
+       echo "exec $miboid $cfg $prog $args" >> $RUN_C
 }
 start() {
        [ -d $LIB_D ] || mkdir -p $LIB_D