tools/dwarves: update to v1.29
authorTony Ambardar <itugrok@yahoo.com>
Wed, 22 Jan 2025 07:00:35 +0000 (23:00 -0800)
committerRobert Marko <robimarko@gmail.com>
Sun, 26 Jan 2025 14:42:44 +0000 (15:42 +0100)
Update to include the latest upstream improvements and bugfixes, including
pahole now always encoding reproducibly.

Drop the local patch:
     100-reproducible-builds.patch

Release Notes: https://lore.kernel.org/bpf/Z4-TDt42dTKZvCo6@x1/
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Link: https://github.com/openwrt/openwrt/pull/17705
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/dwarves/Makefile
tools/dwarves/patches/100-reproducible-builds.patch [deleted file]

index 53461267767afbc005230743643376671462b6a1..56259b260ed170a9da178be4bd68b3b721f49087 100644 (file)
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dwarves
-PKG_VERSION:=1.28
+PKG_VERSION:=1.29
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://fedorapeople.org/~acme/dwarves/
-PKG_HASH:=826efc0fc9237d3c1e9c01553ea387a8cb46e8dc119ff863889043f4ed54b2ae
+PKG_HASH:=59c597d4e953c714d6f3ff36aeed2ac30cba85c1d7b94d0c87ca91d611d98a56
 
 PKG_MAINTAINER:=Tony Ambardar <itugrok@yahoo.com>
 PKG_LICENSE:=GPL-2.0-only
diff --git a/tools/dwarves/patches/100-reproducible-builds.patch b/tools/dwarves/patches/100-reproducible-builds.patch
deleted file mode 100644 (file)
index d8cbd11..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/pahole.c
-+++ b/pahole.c
-@@ -3681,6 +3681,9 @@ int main(int argc, char *argv[])
-               goto out;
-       }
-+      if (getenv("SOURCE_DATE_EPOCH") || getenv("KBUILD_BUILD_TIMESTAMP"))
-+              conf_load.reproducible_build = true;
-+
-       if (dwarves__init()) {
-               fputs("pahole: insufficient memory\n", stderr);
-               goto out;