[packages] netatalk: remove some redundant CFLAG overrides, use autoreconf to ensure...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Oct 2011 14:52:22 +0000 (14:52 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Oct 2011 14:52:22 +0000 (14:52 +0000)
SVN-Revision: 28482

net/netatalk/Makefile
net/netatalk/patches/001-automake-compat.patch [new file with mode: 0644]

index dca1814ad75727b66f6945c0cc78d5e62f603ed3..443ff61418bb4a7a91a26187c65bc21c1a61c2e8 100644 (file)
@@ -17,6 +17,7 @@ PKG_MD5SUM:=4a371025daf96adb73fa491efdbfef28
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -40,13 +41,9 @@ define Package/netatalk/conffiles
 /etc/netatalk/afpd.conf
 endef
 
-EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += -std=c99 -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 TARGET_LDFLAGS += $(LIBRPC)
 
-CONFIGURE_VARS += \
-       CFLAGS="$(TARGET_CFLAGS) -std=gnu99 -DNO_DEBUG "
-
 CONFIGURE_ARGS += \
        --disable-afs \
        --enable-hfs \
diff --git a/net/netatalk/patches/001-automake-compat.patch b/net/netatalk/patches/001-automake-compat.patch
new file mode 100644 (file)
index 0000000..e56b086
--- /dev/null
@@ -0,0 +1,9 @@
+--- a/macros/iconv.m4
++++ b/macros/iconv.m4
+@@ -114,6 +114,5 @@ int main() {
+         CFLAGS="$savedcflags"
+         LDFLAGS="$savedldflags"
+-      CPPFLAGS="$saved_CPPFLAGS"
+       
+ ])