projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e47a2a2
)
kernel: package the usbmon module
author
Gabor Juhos
<juhosg@openwrt.org>
Fri, 19 Jul 2013 22:19:26 +0000
(22:19 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Fri, 19 Jul 2013 22:19:26 +0000
(22:19 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37458
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 9b7d1925aeac26103d646c8034365f7646b30910..64a80e78da38656406b7c3b3018503bb846ed90a 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-1046,3
+1046,16
@@
endef
$(eval $(call KernelPackage,usb-chipidea,1))
+define KernelPackage/usbmon
+ TITLE:=USB traffic monitor
+ KCONFIG:=CONFIG_USB_MON
+ $(call AddDepends/usb)
+ FILES:=$(LINUX_DIR)/drivers/usb/mon/usbmon.ko
+ AUTOLOAD:=$(call AutoLoad,60,usbmon)
+endef
+
+define KernelPackage/usbmon/description
+ Kernel support for USB traffic monitoring.
+endef
+
+$(eval $(call KernelPackage,usbmon))