projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9e4f19c
)
set TOOLCHAIN_DIR var when using external toolchain
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 2 Apr 2011 14:27:51 +0000
(14:27 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 2 Apr 2011 14:27:51 +0000
(14:27 +0000)
This patch allows to use the openwrt toolchain as external toolchain for the
same project. See bug #9131 for details.
Signed-off-by: Sven Bachmann <dev@mcbachmann.de>
SVN-Revision: 26405
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index 428258f5f4af8dca9a4f91b284be15ee2e642459..a3516a57a024e7c084c768c35d1ca1f38830386d 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-140,6
+140,7
@@
ifndef DUMP
ifneq ($(TOOLCHAIN_LIB_DIRS),)
TARGET_LDFLAGS+= $(patsubst %,-L%,$(TOOLCHAIN_LIB_DIRS))
endif
+ TOOLCHAIN_DIR:=$(TOOLCHAIN_ROOT_DIR)
endif
endif
endif