build jffs2 images with both erase block sizes for wr850g (#576)
authorFelix Fietkau <nbd@openwrt.org>
Fri, 9 Jun 2006 02:59:10 +0000 (02:59 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 9 Jun 2006 02:59:10 +0000 (02:59 +0000)
SVN-Revision: 3926

openwrt/target/linux/image/brcm/Makefile

index 9b28eb39142d97b9c1c2c86653a368c9c4170c0a..290d3be0ee898c8b9c81b0824afee5b7fecfe547 100644 (file)
@@ -51,6 +51,10 @@ FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
 # install: $(BIN_DIR)/openwrt-wap54g-$(FSNAME).trx
 # endif
 
+$(BIN_DIR)/openwrt-wr850g-$(FS).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+       $(STAGING_DIR)/bin/motorola-bin -1 $< $@
+
+install: $(BIN_DIR)/openwrt-wr850g-$(FS).bin
 
 ifneq ($(FS),jffs2-8MB)
 $(BIN_DIR)/openwrt-wrt54g3g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
@@ -71,7 +75,7 @@ $(BIN_DIR)/openwrt-wa840g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$
 $(BIN_DIR)/openwrt-we800g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
        $(STAGING_DIR)/bin/motorola-bin -3 $< $@
 
-install: $(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(FSNAME).bin $(BIN_DIR)/openwrt-wr850g-$(FSNAME).bin $(BIN_DIR)/openwrt-wa840g-$(FSNAME).bin $(BIN_DIR)/openwrt-we800g-$(FSNAME).bin
+install: $(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(FSNAME).bin $(BIN_DIR)/openwrt-wa840g-$(FSNAME).bin $(BIN_DIR)/openwrt-we800g-$(FSNAME).bin
 endif
 
 ifneq ($(FS),jffs2-4MB)