projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
aee5c53
)
build: fix compile error when a package includes itself in PROVIDES
author
Felix Fietkau
<nbd@nbd.name>
Fri, 20 Jul 2018 08:40:43 +0000
(10:40 +0200)
committer
Jo-Philipp Wich
<jo@mein.io>
Fri, 20 Jul 2018 13:37:46 +0000
(15:37 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry picked from commit
7c306ae640feb4d42b352175de27b034bd917938
)
include/package-ipkg.mk
patch
|
blob
|
history
diff --git
a/include/package-ipkg.mk
b/include/package-ipkg.mk
index d9b6f77cc441d587675fe1a6e54828b5320b87dc..a9cd51e80fd4ed50d29f27a0d6ccef561ced3e36 100644
(file)
--- a/
include/package-ipkg.mk
+++ b/
include/package-ipkg.mk
@@
-196,7
+196,7
@@
$(_endef)
fi; \
done; $(Package/$(1)/extra_provides) \
) | sort -u > $(PKG_INFO_DIR)/$(1).provides
- $(if $(PROVIDES),@for pkg in $(
PROVIDES
); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$$$pkg.provides; done)
+ $(if $(PROVIDES),@for pkg in $(
filter-out $(1),$(PROVIDES)
); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$$$pkg.provides; done)
$(CheckDependencies)
$(RSTRIP) $$(IDIR_$(1))