build: set PATH for post-install scripts
authorDaniel Golle <daniel@makrotopia.org>
Tue, 5 Nov 2024 03:05:31 +0000 (03:05 +0000)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 5 Nov 2024 10:21:43 +0000 (11:21 +0100)
post-install scripts may need to call executables installed to
STAGING_DIR_HOSTPKG which is not part of the PATH set to TARGET_PATH in
rules.mk.
Set PATH for post-install scripts to TARGET_PATH_PKG.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Link: https://github.com/openwrt/openwrt/pull/16865
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/rootfs.mk

index e6cadc531df75429f8114c83984f0be8726efbda..ff7fd185fe23180c4e47488e8b183875901f6931 100644 (file)
@@ -84,7 +84,7 @@ define prepare_rootfs
                        IPKG_POSTINST_PATH=./usr/lib/opkg/info/*.postinst; \
                fi; \
                for script in $$IPKG_POSTINST_PATH; do \
-                       IPKG_INSTROOT=$(1) $$(command -v bash) $$script; \
+                       PATH="$(TARGET_PATH_PKG)" IPKG_INSTROOT=$(1) $$(command -v bash) $$script; \
                        ret=$$?; \
                        if [ $$ret -ne 0 ]; then \
                                echo "postinst script $$script has failed with exit code $$ret" >&2; \