Fix install permissions and executable bits for rp-pppoe (#2882)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 10 Jan 2008 18:20:34 +0000 (18:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 10 Jan 2008 18:20:34 +0000 (18:20 +0000)
SVN-Revision: 10159

net/rp-pppoe/Makefile

index 2300492c30095980e5032a908fdebef6ff184795..249084a15f5ec759f0f9d5a34f59c25ed1c0bd7c 100644 (file)
@@ -63,7 +63,9 @@ define Package/rp-pppoe-client/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/scripts/pppoe-{connect,start,stop} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-connect $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-start $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-stop $(1)/usr/sbin/
        $(SED) 's,modprobe,insmod,g' $(1)/usr/sbin/pppoe-connect
 endef