tools: e2fsprogs: use standard make uninstall
authorRobert Marko <robimarko@gmail.com>
Tue, 25 Jun 2024 17:45:12 +0000 (19:45 +0200)
committerRobert Marko <robimarko@gmail.com>
Wed, 26 Jun 2024 09:21:04 +0000 (11:21 +0200)
There is no need to manually only remove 2 binaries during cleanup and
leave rest of the e2fsprogs installed stuff untouched, so instead use
make uninstall to do the cleanup.

Link: https://github.com/openwrt/openwrt/pull/15806
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/e2fsprogs/Makefile

index c4895add120a69acd145945645ee46c24a795e2f..1025b7ec5eb16902293694230ae0f4f512c4840e 100644 (file)
@@ -38,9 +38,8 @@ define Host/Prepare
        rm -rf $(HOST_BUILD_DIR)/doc
 endef
 
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/bin/e2fsck
-       rm -f $(STAGING_DIR_HOST)/bin/tune2fs
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))