-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
include $(TOPDIR)/rules.mk
PKG_NAME:=vsftpd
-PKG_VERSION:=2.0.5
+PKG_VERSION:=2.0.6
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_MD5SUM:=146062e8b2f93af43ff6c2c770feea94
+PKG_MD5SUM:=f7a742690d7f86e356fb66d3840079c7
include $(INCLUDE_DIR)/package.mk
define Package/vsftpd/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/vsftpd $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc
- $(INSTALL_CONF) ./files/vsftpd.conf $(1)/etc/vsftpd.conf
+ $(INSTALL_CONF) ./files/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME).conf
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/vsftpd.init $(1)/etc/init.d/vsftpd
+ $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
endef
$(eval $(call BuildPackage,vsftpd))
---- vsftpd-2.0.4-orig/Makefile 2005-06-29 00:24:03.000000000 +0200
-+++ vsftpd-2.0.4/Makefile 2006-01-11 18:29:12.000000000 +0100
+Index: vsftpd-2.0.6/Makefile
+===================================================================
+--- vsftpd-2.0.6.orig/Makefile 2008-04-13 11:41:08.000000000 +0200
++++ vsftpd-2.0.6/Makefile 2008-04-13 11:41:08.000000000 +0200
@@ -17,6 +17,8 @@
ssl.o sysutil.o sysdeputil.o
-diff -ruN vsftpd-1.2.2-orig/Makefile vsftpd-1.2.2-3/Makefile
---- vsftpd-1.2.2-orig/Makefile 2003-09-15 13:41:58.000000000 +0200
-+++ vsftpd-1.2.2-3/Makefile 2005-03-09 22:23:12.000000000 +0100
+Index: vsftpd-2.0.6/Makefile
+===================================================================
+--- vsftpd-2.0.6.orig/Makefile 2008-04-13 11:41:08.000000000 +0200
++++ vsftpd-2.0.6/Makefile 2008-04-13 11:41:08.000000000 +0200
@@ -5,8 +5,8 @@
#CFLAGS = -g
CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
---- vsftpd-2.0.4-orig/tunables.c 2006-01-07 20:32:44.000000000 +0100
-+++ vsftpd-2.0.4/tunables.c 2006-01-11 18:25:15.000000000 +0100
-@@ -92,7 +92,7 @@
- unsigned int tunable_max_per_ip = 0;
- unsigned int tunable_trans_chunk_size = 0;
+Index: vsftpd-2.0.6/tunables.c
+===================================================================
+--- vsftpd-2.0.6.orig/tunables.c 2008-04-13 11:41:08.000000000 +0200
++++ vsftpd-2.0.6/tunables.c 2008-04-13 11:41:09.000000000 +0200
+@@ -100,7 +100,7 @@
+ /* -rw------- */
+ unsigned int tunable_chown_upload_mode = 0600;
-const char* tunable_secure_chroot_dir = "/usr/share/empty";
+const char* tunable_secure_chroot_dir = "/var/run/vsftpd";
-diff -ur vsftpd.old/sysdeputil.c vsftpd.dev/sysdeputil.c
---- vsftpd.old/sysdeputil.c 2005-05-24 00:34:23.000000000 +0200
-+++ vsftpd.dev/sysdeputil.c 2007-03-02 17:50:30.969786936 +0100
+Index: vsftpd-2.0.6/sysdeputil.c
+===================================================================
+--- vsftpd-2.0.6.orig/sysdeputil.c 2008-04-13 11:41:08.000000000 +0200
++++ vsftpd-2.0.6/sysdeputil.c 2008-04-13 11:41:09.000000000 +0200
@@ -159,7 +159,6 @@
#include <linux/capability.h>
#include <errno.h>
/* Gross HACK to avoid warnings - linux headers overlap glibc headers */
#undef __NFDBITS
#undef __FDMASK
-Only in vsftpd.old: vsftpd-2.0.4
sysutil.c: In function 'vsf_sysutil_wait_get_exitcode':
sysutil.c:614: error: assignment of read-only member '__in'
---- vsftpd-2.0.4-old/sysutil.c
-+++ vsftpd-2.0.4-new/sysutil.c
+Index: vsftpd-2.0.6/sysutil.c
+===================================================================
+--- vsftpd-2.0.6.orig/sysutil.c 2008-04-13 11:41:08.000000000 +0200
++++ vsftpd-2.0.6/sysutil.c 2008-04-13 11:41:09.000000000 +0200
@@ -601,7 +601,7 @@
vsf_sysutil_wait_exited_normally(
const struct vsf_sysutil_wait_retval* p_waitret)