projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9b1084b
)
fix kmod packaging for packages where some KCONFIG symbols are set to y
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 2 Aug 2007 13:38:03 +0000
(13:38 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 2 Aug 2007 13:38:03 +0000
(13:38 +0000)
SVN-Revision: 8316
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index 407109f38bcfc6182c2147ca02c0169255e62001..dfdd277dc72d312df553df016ca8f81179abe60b 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-99,7
+99,7
@@
define KernelPackage
$(call KernelPackage/$(1)/$(BOARD)-$(KERNEL))
endef
- if
eq ($(filter y
,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),)
+ if
neq ($(filter m
,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)