projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
84ad178
)
mdadm: use -ffunction-sections, -fdata-sections, --gc-sections
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 28 Jun 2013 11:26:40 +0000
(11:26 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 28 Jun 2013 11:26:40 +0000
(11:26 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37062
package/utils/mdadm/Makefile
patch
|
blob
|
history
diff --git
a/package/utils/mdadm/Makefile
b/package/utils/mdadm/Makefile
index af160481365bdb09ea6460f62e40e21f136f6863..6c4145ad6d1075682fa2bce5a1fdb9041f20d215 100644
(file)
--- a/
package/utils/mdadm/Makefile
+++ b/
package/utils/mdadm/Makefile
@@
-33,6
+33,9
@@
define Package/mdadm/description
A tool for managing Linux Software RAID arrays.
endef
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \