Added support for FILTER in pppd, closes #234
authorFlorian Fainelli <florian@openwrt.org>
Sun, 5 Feb 2006 20:28:34 +0000 (20:28 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 5 Feb 2006 20:28:34 +0000 (20:28 +0000)
SVN-Revision: 3149

openwrt/package/ppp/Config.in
openwrt/package/ppp/Makefile
openwrt/package/ppp/patches/300-filter-pcap-includes-lib.patch [new file with mode: 0644]

index 951c248829aeccaad15a1abd911b4fe56956e7e7..8d3558bec19c10b4576bfaa501423ad7aa326dbf 100644 (file)
@@ -6,6 +6,11 @@ config BR2_PACKAGE_PPP
        default y
        select BR2_PACKAGE_KMOD_PPP
 
+config BR2_PACKAGE_PPP_WITH_FILTER
+        bool "Enable filter support"
+       default y
+       depends BR2_PACKAGE_LIBPCAP
+
 config BR2_PACKAGE_PPP_MOD_PPPOE
        prompt "...-mod-pppoe - PPPoE (PPP over Ethernet) plugin"
        tristate
index bda05e7e9ba8435e4a80e12162fd03e18abc0b41..483df52efe96109245e4231750ce3b7e5dbfb59e 100644 (file)
@@ -37,6 +37,12 @@ $(eval $(call PKG_template,PPPSTATS,pppstats,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(eval $(call PKG_mod_template,PPP_MOD_PPPOE,rp-pppoe))
 $(eval $(call PKG_mod_template,PPP_MOD_RADIUS,radius))
 
+PKG_DEPEND:="kmod-ppp"
+ifeq ($(BR2_PACKAGE_PPP_WITH_FILTER),y)
+ENABLE_FILTER:="FILTER=1"
+PKG_DEPEND += ", libpcap"
+endif
+
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
@@ -71,6 +77,8 @@ $(PKG_BUILD_DIR)/.built:
                CC=$(TARGET_CC) \
                COPTS="$(TARGET_CFLAGS)" \
                HAVE_INET6="1" \
+               $(ENABLE_FILTER) \
+               STAGING_DIR=$(STAGING_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)/usr" \
                all install
        touch $@
@@ -85,6 +93,7 @@ $(IPKG_PPP):
        install -d -m0755 $(IDIR_PPP)/usr/sbin
        install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/pppd $(IDIR_PPP)/usr/sbin/
        install -d -m0755 $(IDIR_PPP)/usr/lib/pppd
+       echo "Depends: $(PKG_DEPEND)" >> $(IDIR_PPP)/CONTROL/control
        $(RSTRIP) $(IDIR_PPP)
        $(IPKG_BUILD) $(IDIR_PPP) $(PACKAGE_DIR)
        
diff --git a/openwrt/package/ppp/patches/300-filter-pcap-includes-lib.patch b/openwrt/package/ppp/patches/300-filter-pcap-includes-lib.patch
new file mode 100644 (file)
index 0000000..3f6247d
--- /dev/null
@@ -0,0 +1,14 @@
+diff -urN ppp-2.4.3.orig/pppd/Makefile.linux ppp-2.4.3/pppd/Makefile.linux
+--- ppp-2.4.3.orig/pppd/Makefile.linux 2006-02-05 20:13:06.000000000 +0100
++++ ppp-2.4.3/pppd/Makefile.linux      2006-02-05 20:24:22.000000000 +0100
+@@ -172,8 +172,8 @@
+ ifdef FILTER
+ ifneq ($(wildcard /usr/include/pcap-bpf.h),)
+-LIBS    += -lpcap
+-CFLAGS  += -DPPP_FILTER
++LIBS    += -lpcap -L$(STAGING_DIR)/usr/lib
++CFLAGS  += -DPPP_FILTER -I$(STAGING_DIR)/usr/include
+ endif
+ endif