projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d081edf
)
rules.mk: reduce shexport to one line to allow it to be put in a target context
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:20 +0000
(08:57 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:20 +0000
(08:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43018
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index 8844a47a1f8aca6b3864bb00283839e40db4cfe5..0822979012d5b985716fe5c24fd278535f388b1e 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-278,8
+278,7
@@
V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
endef
define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
+export $(call shvar,$(1))=$$(call $(1))
endef
define include_mk