projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
81cda3e
)
ar71xx: create initramfs images for the newer TP-Link boards
author
Gabor Juhos
<juhosg@openwrt.org>
Sat, 3 Dec 2011 16:57:23 +0000
(16:57 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Sat, 3 Dec 2011 16:57:23 +0000
(16:57 +0000)
SVN-Revision: 29410
target/linux/ar71xx/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ar71xx/image/Makefile
b/target/linux/ar71xx/image/Makefile
index 73f816f4da0eb72167a3b918638392c26faca87a..411fd1629637258665d2543df81332f6458fe783 100644
(file)
--- a/
target/linux/ar71xx/image/Makefile
+++ b/
target/linux/ar71xx/image/Makefile
@@
-308,6
+308,14
@@
define Image/Build/TPLINK-LZMA
-o $(call sysupname,$(1),$(2))
endef
+define Image/Build/TPLINK-LZMA/initramfs
+ $(call PatchKernelLzma,$(2),$(3))
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
+ -B $(4) -N OpenWrt -V $(REVISION) -s \
+ -k $(KDIR)/vmlinux-$(2).bin.lzma \
+ -o $(call imgname,$(1),$(2))-uImage.bin
+endef
+
define Image/Build/CyberTAN
$(call MkuImageGzip,$(2),$(3))
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR)/vmlinux-$(2).uImage \