samba36: disable some unused modules
authorFelix Fietkau <nbd@openwrt.org>
Mon, 13 Feb 2012 20:57:39 +0000 (20:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 13 Feb 2012 20:57:39 +0000 (20:57 +0000)
SVN-Revision: 30510

net/samba36/Makefile
net/samba36/patches/250-remove_domain_logon.patch

index edeb5fbba76b81775f15111ed29e2cea0a0bbb2e..2dacb318d0f31062861dcfd26e8d6d5ae19ed682 100644 (file)
@@ -90,7 +90,7 @@ CONFIGURE_ARGS += \
        --without-libsmbclient \
        --without-libsmbsharemodes \
        --without-libaddns \
-       --with-shared-modules=
+       --with-shared-modules=pdb_wbc_sam,idmap_nss,nss_info_template,auth_winbind,auth_wbc,auth_domain
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
index 4a726ce7cdefeb65a82b715eb3ce39f4bb8bcb94..2db6524f6bd323d7f34241132b33eb61b256998d 100644 (file)
 +#endif
        return NT_STATUS_OK;
  }
+--- a/source3/smbd/process.c
++++ b/source3/smbd/process.c
+@@ -2483,8 +2483,10 @@ static bool housekeeping_fn(const struct
+       /* check if we need to reload services */
+       check_reload(sconn, time_mono(NULL));
++#ifdef NETLOGON_SUPPORT
+       /* Change machine password if neccessary. */
+       attempt_machine_password_change();
++#endif
+         /*
+        * Force a log file check.