Rename CONFIG_IWL4965 symbol
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 8 Aug 2009 12:38:15 +0000 (14:38 +0200)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 10 Aug 2009 22:41:41 +0000 (15:41 -0700)
In kernel 2.6.26 and older CONFIG_IWL4965 was build as an extra
module, but now it is directly included in the iwlagn.

CONFIG_IWL4965 has to be set to y, to build correctly.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
compat/patches/09-rename-iwl4965-config.patch [new file with mode: 0644]
config.mk

diff --git a/compat/patches/09-rename-iwl4965-config.patch b/compat/patches/09-rename-iwl4965-config.patch
new file mode 100644 (file)
index 0000000..ab4597e
--- /dev/null
@@ -0,0 +1,31 @@
+In kernel 2.6.26 and older CONFIG_IWL4965 was build as an extra
+module, but now it is directly included in the iwlagn.
+
+CONFIG_IWL4965 has to be set to y, to build correctly.
+
+--- a/drivers/net/wireless/iwlwifi/Makefile
++++ b/drivers/net/wireless/iwlwifi/Makefile
+@@ -9,7 +9,7 @@ iwlcore-$(CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT) += iwl-spectrum.o
+ obj-$(CONFIG_IWLAGN)  += iwlagn.o
+ iwlagn-objs           := iwl-agn.o iwl-agn-rs.o
+-iwlagn-$(CONFIG_IWL4965) += iwl-4965.o
++iwlagn-$(CONFIG_COMPAT_IWL4965) += iwl-4965.o
+ iwlagn-$(CONFIG_IWL5000) += iwl-5000.o
+ iwlagn-$(CONFIG_IWL5000) += iwl-6000.o
+ iwlagn-$(CONFIG_IWL5000) += iwl-1000.o
+--- a/drivers/net/wireless/iwlwifi/iwl-agn.c
++++ b/drivers/net/wireless/iwlwifi/iwl-agn.c
+@@ -3088,10 +3088,10 @@ static void __devexit iwl_pci_remove(struct pci_dev *pdev)
+ /* Hardware specific file defines the PCI IDs table for that hardware module */
+ static struct pci_device_id iwl_hw_card_ids[] = {
+-#ifdef CONFIG_IWL4965
++#ifdef CONFIG_COMPAT_IWL4965
+       {IWL_PCI_DEVICE(0x4229, PCI_ANY_ID, iwl4965_agn_cfg)},
+       {IWL_PCI_DEVICE(0x4230, PCI_ANY_ID, iwl4965_agn_cfg)},
+-#endif /* CONFIG_IWL4965 */
++#endif /* CONFIG_COMPAT_IWL4965 */
+ #ifdef CONFIG_IWL5000
+       {IWL_PCI_DEVICE(0x4232, 0x1205, iwl5100_bg_cfg)},
+       {IWL_PCI_DEVICE(0x4232, 0x1305, iwl5100_bg_cfg)},
index 0d8962bbb74ec634f5a2123fd053f8c070cbd7ae..2dab9afbe36a0c8410406d0ccdc89788f2d68b23 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -135,7 +135,7 @@ CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT=y
 # CONFIG_IWLWIFI_DEBUG=y
 # CONFIG_IWLWIFI_DEBUGFS=y
 CONFIG_IWLAGN=m
-CONFIG_IWL4965=y
+CONFIG_COMPAT_IWL4965=y
 CONFIG_IWL5000=y
 CONFIG_IWL3945=m
 CONFIG_IWL3945_SPECTRUM_MEASUREMENT=y