packages/bind: ship a working named.conf file, add missing conffiles define
authorNicolas Thill <nico@openwrt.org>
Wed, 16 Nov 2011 20:02:31 +0000 (20:02 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 16 Nov 2011 20:02:31 +0000 (20:02 +0000)
SVN-Revision: 29197

net/bind/Makefile

index 8c547d7eaf15b3fe84db44e4eaf57528e13844b4..f547befbcabe1de444ae29d811c5d7a670c3e0aa 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
 PKG_VERSION:=9.8.0-P4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -112,13 +112,29 @@ endef
 define Package/bind-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/named $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(CP) ./files/bind $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/bind
+       $(CP) \
+               ./files/bind/db.0 \
+               ./files/bind/db.127 \
+               ./files/bind/db.255 \
+               ./files/bind/db.local \
+               ./files/bind/db.root \
+               $(1)/etc/bind/
+       $(CP) ./files/bind/named.conf.example $(1)/etc/bind/named.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/named.init $(1)/etc/init.d/named
        find $(1)/etc/bind/ -name ".svn" | xargs rm -rf
 endef
 
+define Package/bind-server/conffiles
+/etc/bind/db.0
+/etc/bind/db.127
+/etc/bind/db.255
+/etc/bind/db.local
+/etc/bind/db.root
+/etc/bind/named.conf
+endef
+
 define Package/bind-client/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nsupdate $(1)/usr/bin/