mdadm: backport musl patch
authorRosen Penev <rosenp@gmail.com>
Sat, 9 Nov 2024 23:46:26 +0000 (15:46 -0800)
committerRobert Marko <robimarko@gmail.com>
Mon, 11 Nov 2024 20:20:01 +0000 (21:20 +0100)
Needed to fix compilation with GCC14.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16912
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/utils/mdadm/Makefile
package/utils/mdadm/patches/060-gcc14.patch [new file with mode: 0644]

index c2778fe351cb3ae3ac88ee5b39893d763cca0f68..b521daaefc92b2c4b1a1c4bf243ed677e9bcdb16 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mdadm
 PKG_VERSION:=4.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/raid/mdadm
diff --git a/package/utils/mdadm/patches/060-gcc14.patch b/package/utils/mdadm/patches/060-gcc14.patch
new file mode 100644 (file)
index 0000000..545a40a
--- /dev/null
@@ -0,0 +1,24 @@
+From 8bda86099089b44129ef6206764f9de47a45f0db Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Tue, 12 Mar 2024 11:01:50 +0100
+Subject: [PATCH] util.c: add limits.h include for NAME_MAX definition
+
+Add limits.h include for NAME_MAX definition.
+
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+Signed-off-by: Mariusz Tkaczyk <mariusz.tkaczyk@linux.intel.com>
+---
+ util.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/util.c
++++ b/util.c
+@@ -36,7 +36,7 @@
+ #include      <ctype.h>
+ #include      <dirent.h>
+ #include      <dlfcn.h>
+-
++#include      <limits.h>
+ /*
+  * following taken from linux/blkpg.h because they aren't