[packages] liboil:
authorNicolas Thill <nico@openwrt.org>
Mon, 21 Apr 2008 21:58:12 +0000 (21:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 21 Apr 2008 21:58:12 +0000 (21:58 +0000)
 - change dependency on libnotimpl to build-time only
 - don't package .so symlink
 - fix pkgconfig
 - bumb release number

SVN-Revision: 10905

libs/liboil/Makefile
libs/liboil/patches/002-pkgconfig.patch [new file with mode: 0644]

index b8f65c10d13891b8b6ca258f3931ad9debf6df45..ae1814c9df634a679e39304d3bf8a092501f52bd 100644 (file)
@@ -1,21 +1,22 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id:$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=liboil
 PKG_VERSION:=0.3.12
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
 PKG_MD5SUM:=96ee4c627ffb0db3999cef3c7454b1d9
 
+PKG_BUILD_DEPENDS:=libnotimpl
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
@@ -23,7 +24,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/liboil
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libnotimpl
   TITLE:=simple functions optimized for various CPUs
   URL:=http://liboil.freedesktop.org/wiki/
 endef
@@ -54,18 +54,17 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/liboil-0.3/ $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/liboil-0.3 $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_BUILD_DIR)/liboil.pc $(1)/usr/lib/pkgconfig/
-       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/liboil.pc
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/liboil-0.3.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/liboil/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liboil-0.3.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,liboil))
diff --git a/libs/liboil/patches/002-pkgconfig.patch b/libs/liboil/patches/002-pkgconfig.patch
new file mode 100644 (file)
index 0000000..e820b4a
--- /dev/null
@@ -0,0 +1,19 @@
+--- liboil-0.3.12/liboil.pc.in.orig    2006-10-11 07:12:30.000000000 +0200
++++ liboil-0.3.12/liboil.pc.in 2008-04-04 10:22:24.000000000 +0200
+@@ -1,7 +1,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+-includedir=@includedir@/liboil-@LIBOIL_MAJORMINOR@
++includedir=@includedir@
+ toolsdir=${exec_prefix}/bin
+@@ -9,6 +9,6 @@
+ Description: Library of Optimized Inner Loops
+ Version: @VERSION@
+ Libs: -L${libdir} -loil-@LIBOIL_MAJORMINOR@ -lm
+-Cflags: -I${includedir}
++Cflags: -I${includedir}/liboil-@LIBOIL_MAJORMINOR@