kernel: Make kmod-usb-chipidea select kmod-phy-ath79-usb
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 24 Jan 2025 21:56:59 +0000 (22:56 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 25 Jan 2025 12:34:13 +0000 (13:34 +0100)
The USB PHY on the ar9330 and similar SoCs needs the PHY driver. In
OpenWrt 23.05 it was compiled into the kernel. The kernel 6.6
configuration does not compile it in any more, make the
kmod-usb-chipidea driver select it to add it to the images.

Fixes: https://github.com/openwrt/openwrt/issues/17710
Fixes: 04bdf9b3323e ("ath79: disable ath79 USB phy drivers by default")
Link: https://github.com/openwrt/openwrt/pull/17720
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit b467e5a0afebbc4982213c03f90dfc6deb717b36)

package/kernel/linux/modules/usb.mk

index 8f934800fc64103a7824aef36241cc74a1c8751e..481d2be59a201ee14f2c99cbfe7a3c7ab8e38363 100644 (file)
@@ -1737,7 +1737,7 @@ $(eval $(call KernelPackage,usbip-server))
 
 define KernelPackage/usb-chipidea
   TITLE:=Host and device support for Chipidea controllers
-  DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget @TARGET_ath79 +kmod-usb-ehci +kmod-usb-phy-nop +kmod-usb-roles
+  DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget @TARGET_ath79 +kmod-usb-ehci +kmod-usb-phy-nop +kmod-usb-roles +kmod-phy-ath79-usb
   KCONFIG:= \
        CONFIG_EXTCON \
        CONFIG_USB_CHIPIDEA \