projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
51c6b14
)
ramips: don't reuse KERNEL_DTB for lzma-loader
author
Chuanhong Guo
<gch981213@gmail.com>
Sat, 18 Apr 2020 05:40:31 +0000
(13:40 +0800)
committer
Chuanhong Guo
<gch981213@gmail.com>
Sat, 18 Apr 2020 05:40:31 +0000
(13:40 +0800)
mt7621 overrides KERNEL_DTB to limit dictionary size, which isn't needed
for our lzma loader.
This saves 15KB on mt7621 devices using uimage-lzma-loader.
Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ramips/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ramips/image/Makefile
b/target/linux/ramips/image/Makefile
index a966ba43490923cbff1b974615ef293cd27dc696..f93ea8ab2aea0e02b4ffdb5027d7db1d4c3fea25 100644
(file)
--- a/
target/linux/ramips/image/Makefile
+++ b/
target/linux/ramips/image/Makefile
@@
-39,7
+39,7
@@
endef
define Device/uimage-lzma-loader
LOADER_TYPE := bin
- KERNEL :=
$(KERNEL_DTB)
| loader-kernel | uImage none
+ KERNEL :=
kernel-bin | append-dtb | lzma
| loader-kernel | uImage none
endef
define Device/seama