projects
/
openwrt
/
svn-archive
/
feeds.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a8c4200
)
lxtask: Force include of libintl.h to avoid implicit linkage to intl functions.
author
Michael Büsch
<mb@bu3sch.de>
Thu, 27 Jan 2011 19:04:38 +0000
(19:04 +0000)
committer
Michael Büsch
<mb@bu3sch.de>
Thu, 27 Jan 2011 19:04:38 +0000
(19:04 +0000)
SVN-Revision: 25158
lxde/apps/lxtask/Makefile
patch
|
blob
|
history
diff --git
a/lxde/apps/lxtask/Makefile
b/lxde/apps/lxtask/Makefile
index e78cb44730f9adbf5e60aa3c926468e4292a6436..c1bd2acf4327e65825b56616886e3e3549ba38e3 100644
(file)
--- a/
lxde/apps/lxtask/Makefile
+++ b/
lxde/apps/lxtask/Makefile
@@
-22,7
+22,8
@@
include $(INCLUDE_DIR)/package.mk
TARGET_CFLAGS+= \
-I$(STAGING_DIR)/usr/lib/libintl/include/ \
- -I$(STAGING_DIR)/usr/lib/libiconv/include/
+ -I$(STAGING_DIR)/usr/lib/libiconv/include/ \
+ -include $(STAGING_DIR)/usr/include/libintl.h
TARGET_LDFLAGS+= \
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
@@
-34,7
+35,7
@@
define Package/lxtask
CATEGORY:=Xorg
SUBMENU:=app
TITLE:=lxtask
- DEPENDS:=+gtk2 +lxde-common
+ DEPENDS:=+gtk2 +lxde-common
+libintl +libiconv
endef
define Package/lxtask/install