projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6ef8736
)
don't use gcc_s on avr32 - fixes uclibc++ compile
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 5 Aug 2008 02:34:32 +0000
(
02:34
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 5 Aug 2008 02:34:32 +0000
(
02:34
+0000)
SVN-Revision: 12121
libs/uclibc++/Makefile
patch
|
blob
|
history
diff --git
a/libs/uclibc++/Makefile
b/libs/uclibc++/Makefile
index 3b438fefb1e7a7d8f8a1b66a4b4eedc75bab0595..688c5d2dde9c0de88aa2797a93be9f8fb17b9209 100644
(file)
--- a/
libs/uclibc++/Makefile
+++ b/
libs/uclibc++/Makefile
@@
-47,6
+47,9
@@
MAKE_FLAGS:= \
ARCH_CFLAGS="$(TARGET_CFLAGS)" \
CROSS="$(TARGET_CROSS)" \
CP="$(CP)" \
+ $(if $(CONFIG_TARGET_avr32),check_as_needed=)
+
+# check_as_needed overrides dependency on libgcc_s
define Build/Configure
if [ -f ./files/config.$(UCLIBC_TARGET_ARCH) ]; then \