mc: add a patch to fix the annoying error message about missing Syntax file (#2133)
authorOliver Ertl <oliver@ertl-net.net>
Thu, 26 Jul 2007 15:44:00 +0000 (15:44 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Thu, 26 Jul 2007 15:44:00 +0000 (15:44 +0000)
SVN-Revision: 8182

utils/mc/Makefile
utils/mc/patches/100-fix-missingsyntax.patch [new file with mode: 0644]

index f688d218b3e5f27661a060266afa91672836c323..67d7591ace5c4ff22e8a3b6b82b8338d90af9a9d 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mc
 PKG_VERSION:=4.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/
diff --git a/utils/mc/patches/100-fix-missingsyntax.patch b/utils/mc/patches/100-fix-missingsyntax.patch
new file mode 100644 (file)
index 0000000..3e4f737
--- /dev/null
@@ -0,0 +1,19 @@
+Index: mc-4.6.1/edit/syntax.c
+===================================================================
+--- mc-4.6.1.orig/edit/syntax.c        2007-07-26 17:35:14.000000000 +0200
++++ mc-4.6.1/edit/syntax.c     2007-07-26 17:35:14.000000000 +0200
+@@ -1113,13 +1113,8 @@
+     f = catstrs (home_dir, SYNTAX_FILE, (char *) NULL);
+     r = edit_read_syntax_file (edit, names, f, edit ? edit->filename : 0,
+                              get_first_editor_line (edit), type);
+-    if (r == -1) {
+-      edit_free_syntax_rules (edit);
+-      message (D_ERROR, _(" Load syntax file "),
+-               _(" Cannot open file %s \n %s "), f,
+-               unix_error_string (errno));
++    if (r == -1) 
+       return;
+-    }
+     if (r) {
+       edit_free_syntax_rules (edit);
+       message (D_ERROR, _(" Load syntax file "),