Added support for USB serial devices, closes #80
authorFlorian Fainelli <florian@openwrt.org>
Thu, 12 Jan 2006 11:42:33 +0000 (11:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 12 Jan 2006 11:42:33 +0000 (11:42 +0000)
SVN-Revision: 2933

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-usb-serial.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index ff48d89604fc22dafbabdbb404ca22aef7bd0286..e65c2f017e7ed30df0b3729bbb5341d264bec5b4 100644 (file)
@@ -230,6 +230,11 @@ config BR2_PACKAGE_KMOD_USB2
        depends BR2_PACKAGE_KMOD_USB
        select BR2_PACKAGE_KMOD_USB_CONTROLLER
 
+config BR2_PACKAGE_KMOD_USB_SERIAL
+        tristate "Support for serial USB devices" 
+       default m 
+       depends BR2_PACKAGE_KMOD_USB_CONTROLLER
+
 config BR2_PACKAGE_KMOD_USB_STORAGE
        tristate "Support for USB storage devices"
        default m
diff --git a/openwrt/target/linux/control/kmod-usb-serial.control b/openwrt/target/linux/control/kmod-usb-serial.control
new file mode 100644 (file)
index 0000000..d29a242
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-usb-serial
+Priority: optional
+Section: sys
+Description: Kernel modules for serial USB support
index 4e586869b08a73ac05cee4899004e42bf33bd9f0..87f59c5864fa3af305222536e9bb7151c5e9c5ce 100644 (file)
@@ -136,6 +136,9 @@ $(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
        $(MODULES_DIR)/kernel/drivers/scsi/*.o \
        $(MODULES_DIR)/kernel/drivers/usb/storage/*.o \
 ,CONFIG_USB_STORAGE,kmod-usb-core,60,scsi_mod sd_mod usb-storage))
+$(eval $(call KMOD_template,USB_SERIAL,usb-serial,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/*.o \
+,CONFIG_USB_SERIAL,kmod-usb-serial,60,usb-serial))
 $(eval $(call KMOD_template,USB_PRINTER,usb-printer,\
        $(MODULES_DIR)/kernel/drivers/usb/printer.o \
 ,CONFIG_USB_PRINTER,kmod-usb-core,60,printer))
index 250e12e8aea8f619be72e47773013b5bc84cb26b..ff0513d923bc05536a06aecc65be2402d73b8ace 100644 (file)
@@ -1195,7 +1195,33 @@ CONFIG_USB_PWC=m
 #
 # USB Serial Converter support
 #
-# CONFIG_USB_SERIAL is not set
+CONFIG_USB_SERIAL=m
+# CONFIG_USB_SERIAL_DEBUG is not set
+CONFIG_USB_SERIAL_GENERIC=y
+# CONFIG_USB_SERIAL_BELKIN is not set
+# CONFIG_USB_SERIAL_WHITEHEAT is not set
+# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
+# CONFIG_USB_SERIAL_EMPEG is not set
+# CONFIG_USB_SERIAL_FTDI_SIO is not set
+# CONFIG_USB_SERIAL_VISOR is not set
+# CONFIG_USB_SERIAL_IPAQ is not set
+# CONFIG_USB_SERIAL_IR is not set
+# CONFIG_USB_SERIAL_EDGEPORT is not set
+# CONFIG_USB_SERIAL_EDGEPORT_TI is not set
+# CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
+# CONFIG_USB_SERIAL_KEYSPAN is not set
+# CONFIG_USB_SERIAL_MCT_U232 is not set
+# CONFIG_USB_SERIAL_KLSI is not set
+# CONFIG_USB_SERIAL_KOBIL_SCT is not set
+# CONFIG_USB_SERIAL_PL2303 is not set
+# CONFIG_USB_SERIAL_CYBERJACK is not set
+# CONFIG_USB_SERIAL_XIRCOM is not set
+# CONFIG_USB_SERIAL_OMNINET is not set
+# CONFIG_USB_RIO500 is not set
+# CONFIG_USB_AUERSWALD is not set
+# CONFIG_USB_TIGL is not set
+# CONFIG_USB_BRLVGER is not set
+# CONFIG_USB_LCD is not set
 # CONFIG_USB_RIO500 is not set
 # CONFIG_USB_AUERSWALD is not set
 # CONFIG_USB_TIGL is not set