[Packages]:
authorOliver Ertl <oliver@ertl-net.net>
Tue, 12 Feb 2008 11:36:34 +0000 (11:36 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Tue, 12 Feb 2008 11:36:34 +0000 (11:36 +0000)
Add libs/libshout (added from: http://lists.openwrt.org/pipermail/openwrt-devel/2008-February/001704.html)

Signed-off-by: Michael Vogt <michu at neophob.com>
SVN-Revision: 10445

libs/libshout/Makefile [new file with mode: 0644]
libs/libshout/patches/100-ogg-c.patch [new file with mode: 0644]
libs/libshout/patches/110-shout-ogg-c.patch [new file with mode: 0644]
libs/libshout/patches/120-vorbis-c.patch [new file with mode: 0644]
libs/libshout/patches/140-no_example_doc_win32.patch [new file with mode: 0644]

diff --git a/libs/libshout/Makefile b/libs/libshout/Makefile
new file mode 100644 (file)
index 0000000..895b750
--- /dev/null
@@ -0,0 +1,68 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libshout
+PKG_VERSION:=2.2.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
+PKG_MD5SUM:=4f75fc9901c724b712c371c9a1e782d3
+
+PKG_FIXUP = libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libshout
+  SECTION:=libs
+  DEPENDS:=+libvorbisidec
+  CATEGORY:=Libraries
+  TITLE:=Library which can be used to write a source client like ices
+  URL:=http://www.icecast.org/download.php
+endef
+
+define Package/libshout/description
+       libshout allows applications to easily communicate and broadcast
+       to an Icecast streaming media server. It handles the socket connections,
+       metadata communication, and data streaming for the calling application,
+       and lets developers focus on feature sets instead of implementation
+       details.
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               VORBIS_CFLAGS="$(STAGING_DIR)/usr/include/tremor"\
+               VORBIS_LIBS="$(STAGING_DIR)/usr/lib" \
+               --enable-shared \
+               --enable-static \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)/usr/include/shout
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/shout/shout.h $(1)/usr/include/shout
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc $(1)/usr/lib/pkgconfig/             
+endef
+
+define Package/libshout/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libshout))
diff --git a/libs/libshout/patches/100-ogg-c.patch b/libs/libshout/patches/100-ogg-c.patch
new file mode 100644 (file)
index 0000000..4313986
--- /dev/null
@@ -0,0 +1,13 @@
+Index: libshout-2.2.2/src/ogg.c
+===================================================================
+--- libshout-2.2.2.orig/src/ogg.c      2008-02-12 12:30:14.000000000 +0100
++++ libshout-2.2.2/src/ogg.c   2008-02-12 12:30:14.000000000 +0100
+@@ -30,7 +30,7 @@
+ #include <inttypes.h>
+ #endif
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ #include <shout/shout.h>
+ #include "shout_private.h"
diff --git a/libs/libshout/patches/110-shout-ogg-c.patch b/libs/libshout/patches/110-shout-ogg-c.patch
new file mode 100644 (file)
index 0000000..d495570
--- /dev/null
@@ -0,0 +1,13 @@
+Index: libshout-2.2.2/src/shout_ogg.h
+===================================================================
+--- libshout-2.2.2.orig/src/shout_ogg.h        2008-02-12 12:30:14.000000000 +0100
++++ libshout-2.2.2/src/shout_ogg.h     2008-02-12 12:30:14.000000000 +0100
+@@ -28,7 +28,7 @@
+ #include <stdlib.h>
+-#include <ogg/ogg.h>
++#include <tremor/ogg.h>
+ typedef struct _ogg_codec_tag {
+       ogg_stream_state os;
diff --git a/libs/libshout/patches/120-vorbis-c.patch b/libs/libshout/patches/120-vorbis-c.patch
new file mode 100644 (file)
index 0000000..ab5bcee
--- /dev/null
@@ -0,0 +1,13 @@
+Index: libshout-2.2.2/src/vorbis.c
+===================================================================
+--- libshout-2.2.2.orig/src/vorbis.c   2008-02-12 12:30:14.000000000 +0100
++++ libshout-2.2.2/src/vorbis.c        2008-02-12 12:30:14.000000000 +0100
+@@ -27,7 +27,7 @@
+ #include <inttypes.h>
+ #endif
+-#include <vorbis/codec.h>
++#include <tremor/ivorbiscodec.h>
+ #include "shout_private.h"
+ #include "shout_ogg.h"
diff --git a/libs/libshout/patches/140-no_example_doc_win32.patch b/libs/libshout/patches/140-no_example_doc_win32.patch
new file mode 100644 (file)
index 0000000..329a1b3
--- /dev/null
@@ -0,0 +1,21 @@
+Index: libshout-2.2.2/Makefile.in
+===================================================================
+--- libshout-2.2.2.orig/Makefile.in    2008-02-12 12:30:14.000000000 +0100
++++ libshout-2.2.2/Makefile.in 2008-02-12 12:30:15.000000000 +0100
+@@ -246,14 +246,14 @@
+ target_alias = @target_alias@
+ AUTOMAKE_OPTIONS = 1.6 foreign
+ ACLOCAL_AMFLAGS = -I m4
+-SUBDIRS = include src examples debian doc win32
++SUBDIRS = include src debian
+ EXTRA_DIST = INSTALL m4/shout.m4 m4/ac_config_libconfig_in.m4 m4/acx_pthread.m4 \
+       m4/ogg.m4 m4/vorbis.m4 m4/xiph_compiler.m4 m4/xiph_net.m4 \
+       m4/xiph_types.m4
+ DISTCLEANFILES = shout-config.in
+ docdir = $(datadir)/doc/$(PACKAGE)
+-doc_DATA = COPYING NEWS README examples/example.c examples/nonblocking.c
++doc_DATA = COPYING NEWS README
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = m4/shout.m4
+ @HAVE_PKGCONFIG_TRUE@pkgconfigdir = $(libdir)/pkgconfig