kernel: modules: fix led-group-multi-color patch
authorJohn Crispin <john@phrozen.org>
Thu, 12 Dec 2024 12:52:43 +0000 (13:52 +0100)
committerJohn Crispin <john@phrozen.org>
Thu, 12 Dec 2024 12:53:54 +0000 (13:53 +0100)
Fixes: 5fd86d6 ("kernel: modules: add support for led-group-multicolor")
Signed-off-by: John Crispin <john@phrozen.org>
package/kernel/linux/modules/leds.mk

index f6f74283eeec4a6799eacd037b07481bd34cb33d..6c619b658eda22b2ad8023b312a50873b722ca86 100644 (file)
@@ -22,21 +22,20 @@ endef
 
 $(eval $(call KernelPackage,leds-gpio))
 
-define KernelPackage/led-group-multicolor
-        SUBMENU:=$(LEDS_MENU)
-        TITLE:=LEDs group multi-color support
-        KCONFIG:= \
-            CONFIG_LEDS_CLASS_MULTICOLOR \
-            CONFIG_LEDS_GROUP_MULTICOLOR
-         FILES:=$(LINUX_DIR)/drivers/leds/rgb/leds-group-multicolor.ko
-        AUTOLOAD:=$(call AutoProbe,led-group-multi-color)
+define KernelPackage/led-group-multi-color
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=LEDs group multi-color support
+  KCONFIG:=CONFIG_LEDS_CLASS_MULTICOLOR \
+     CONFIG_LEDS_GROUP_MULTICOLOR
+  FILES:=$(LINUX_DIR)/drivers/leds/rgb/leds-group-multicolor.ko
+  AUTOLOAD:=$(call AutoProbe,led-group-multi-color)
 endef
 
 define KernelPackage/led-group-multi-color/description
       This option enables support for monochrome LEDs that are grouped
       into multicolor LEDs which is useful in the case where LEDs of
       different colors are physically grouped in a single multi-color LED
       and driven by a controller that does not have multi-color support.
+ This option enables support for monochrome LEDs that are grouped
+ into multicolor LEDs which is useful in the case where LEDs of
+ different colors are physically grouped in a single multi-color LED
+ and driven by a controller that does not have multi-color support.
 endef
 
 $(eval $(call KernelPackage,led-group-multi-color))