backports: remove extra BACKPORT_ prefix from kernel versioning
authorLuis R. Rodriguez <mcgrof@suse.com>
Wed, 5 Nov 2014 02:14:29 +0000 (18:14 -0800)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Fri, 14 Nov 2014 21:47:17 +0000 (13:47 -0800)
The CPTCFG_ prefix already implies backport, when integration
is used we'd end up with a double BACKPORT_ prefix, so just
remove the existing one as its not needed.

Signed-off-by: Luis R. Rodriguez <mcgrof@suse.com>
backport/Makefile
backport/compat/Kconfig
backport/compat/Makefile
devel/doc/kconfig-operation
gentree.py
patches/collateral-evolutions/media/0002-no_dmabuf/v4l2.patch

index fcf2f0159a4c96c24b6d12523fb8fe6d57c61b52..c21b81350d6a858fda5b01ac19ea888232207615 100644 (file)
@@ -93,7 +93,7 @@ mrproper:
                print=0                                                                 ;\
                for v in $$kvers ; do                                                   \
                        if [ "$$print" = "1" ] ; then                                   \
-                               echo config BACKPORT_KERNEL_$$(echo $$v | tr . _)       ;\
+                               echo config KERNEL_$$(echo $$v | tr . _)        ;\
                                echo "    def_bool y"                                   ;\
                        fi                                                              ;\
                        if [ "$$v" = "$$kver" ] ; then print=1 ; fi                     ;\
index 06ef8d544285ebdd3dc2e7fe0c4b512f376cb4e0..aadf246896e91e8c104b0e8dbbe238e2fc2077b3 100644 (file)
 #
 #      # not possible on kernel < X.Y, build will fail if any
 #      # drivers are allowed to build on kernels < X.Y
-#      depends on BACKPORT_KERNEL_X_Y
+#      depends on KERNEL_X_Y
 #
 #      # don't build the backport code if FOO is in the kernel
 #      # already, but only if the kernel version is also >= X.Z;
 #      # this is an example of backporting where the version of
 #      # the FOO subsystem that we need is only available from
 #      # kernel version X.Z
-#      depends on !FOO || BACKPORT_KERNEL_X_Z
+#      depends on !FOO || KERNEL_X_Z
 #
 #      # build if driver needs it (it selects BPAUTO_FOO)
 #      default m if BPAUTO_FOO
@@ -43,7 +43,7 @@
 #
 # config BPAUTO_BUILD_KFIFO
 #      def_bool y
-#      depends on BACKPORT_KERNEL_2_6_36
+#      depends on KERNEL_2_6_36
 #
 #
 # C) similarly, a kconfig symbol for an option, e.g.
@@ -83,9 +83,9 @@ config BPAUTO_BUILD_DMA_SHARED_HELPERS
        depends on HAS_DMA
        # Build on other kernels kernels < 3.9 if HAVE_GENERIC_DMA_COHERENT is
        # not set. Kernels >= 3.8 have this if HAS_DMA is set.
-       depends on (!HAVE_GENERIC_DMA_COHERENT || BACKPORT_KERNEL_3_9)
+       depends on (!HAVE_GENERIC_DMA_COHERENT || KERNEL_3_9)
        # Always build if on 3.3 - 3.5
-       default y if (BACKPORT_KERNEL_3_4 || BACKPORT_KERNEL_3_5 || BACKPORT_KERNEL_3_6)
+       default y if (KERNEL_3_4 || KERNEL_3_5 || KERNEL_3_6)
        # build for testing
        default y if BPAUTO_USERSEL_BUILD_ALL
 
index 0dd69fe426344755a2244faf65de04b58fd5e883..e787763be1fe01a2a1c2ace4b90e362c44b0367c 100644 (file)
@@ -3,23 +3,23 @@ obj-m += compat.o
 compat-y += main.o
 
 # Kernel backport compatibility code
-compat-$(CPTCFG_BACKPORT_KERNEL_3_0) += compat-3.0.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_1) += compat-3.1.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_2) += backport-3.2.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_3) += compat-3.3.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_4) += compat-3.4.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_5) += compat-3.5.o user_namespace.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_6) += compat-3.6.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_7) += compat-3.7.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_8) += compat-3.8.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_9) += compat-3.9.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_10) += backport-3.10.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_12) += backport-3.12.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_13) += backport-3.13.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_14) += backport-3.14.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_15) += backport-3.15.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_17) += backport-3.17.o
-compat-$(CPTCFG_BACKPORT_KERNEL_3_18) += backport-3.18.o
+compat-$(CPTCFG_KERNEL_3_0) += compat-3.0.o
+compat-$(CPTCFG_KERNEL_3_1) += compat-3.1.o
+compat-$(CPTCFG_KERNEL_3_2) += backport-3.2.o
+compat-$(CPTCFG_KERNEL_3_3) += compat-3.3.o
+compat-$(CPTCFG_KERNEL_3_4) += compat-3.4.o
+compat-$(CPTCFG_KERNEL_3_5) += compat-3.5.o user_namespace.o
+compat-$(CPTCFG_KERNEL_3_6) += compat-3.6.o
+compat-$(CPTCFG_KERNEL_3_7) += compat-3.7.o
+compat-$(CPTCFG_KERNEL_3_8) += compat-3.8.o
+compat-$(CPTCFG_KERNEL_3_9) += compat-3.9.o
+compat-$(CPTCFG_KERNEL_3_10) += backport-3.10.o
+compat-$(CPTCFG_KERNEL_3_12) += backport-3.12.o
+compat-$(CPTCFG_KERNEL_3_13) += backport-3.13.o
+compat-$(CPTCFG_KERNEL_3_14) += backport-3.14.o
+compat-$(CPTCFG_KERNEL_3_15) += backport-3.15.o
+compat-$(CPTCFG_KERNEL_3_17) += backport-3.17.o
+compat-$(CPTCFG_KERNEL_3_18) += backport-3.18.o
 
 compat-$(CPTCFG_BPAUTO_BUILD_CRYPTO_CCM) += crypto-ccm.o
 compat-$(CPTCFG_BPAUTO_BUILD_DMA_SHARED_HELPERS) += dma-shared-helpers.o
index f1ecf60953bed5258dcaca72ed915d24fd321f60..ddb4de77b1344c9f711858c384700e61cbf7a9f0 100644 (file)
@@ -53,12 +53,12 @@ The second file (Kconfig.versions) is generated from just the version of
 the kernel and also contains invisible and unselectable boolean options
 like
 
-config BACKPORT_KERNEL_X
+config KERNEL_X
     def_bool y
 
 to indicate that APIs introduced in kernel version X (e.g. 3_3 for 3.3
 or 2_6_24 for 2.6.24) must be backported. Essentially, the presence of
-a symbol BACKPORT_KERNEL_X indicates that the kernel that the code is
+a symbol KERNEL_X indicates that the kernel that the code is
 being compiled against is older than X.
 
 All together, this allows the correct options to be selected by the user.
@@ -121,7 +121,7 @@ These are the problems and their solutions:
     requires at least 2.6.29 due to the shash crypto code. This cannot be
     determined easily automatically, so the 'dependencies' file is read
     and options that are listed there are rewritten to include
-        depends on !BACKPORT_KERNEL_X_Y
+        depends on !KERNEL_X_Y
     (where X_Y is the listed kernel version), which makes them available
     only on kernels >= X.Y.
 
index bf2112bcdc598608f45fef6239c4456d690496cf..90334ef7b3bde657772e5b81c84559cc449a682b 100755 (executable)
@@ -988,7 +988,7 @@ def process(kerneldir, copy_list_file, git_revision=None,
             elif (dep == "DISABLE"):
                     new.append('BACKPORT_DISABLED_KCONFIG_OPTION')
             else:
-                    new.append('!BACKPORT_KERNEL_%s' % dep.replace('.', '_'))
+                    new.append('!KERNEL_%s' % dep.replace('.', '_'))
         if bpid.integrate:
             deplist[sym] = ["BACKPORT_" + x for x in new]
         else:
index 02d042a00ad9e2e78dee74d0212a3b6ba90ff0cf..7f88c3e1c2c193ec964910f79a07c9495c3f5c0d 100644 (file)
@@ -5,7 +5,7 @@
  # Used by drivers that need Videobuf2 modules
  config VIDEOBUF2_CORE
 -      select DMA_SHARED_BUFFER
-+      select DMA_SHARED_BUFFER if !BACKPORT_KERNEL_3_5
++      select DMA_SHARED_BUFFER if !KERNEL_3_5
        tristate
  
  config VIDEOBUF2_MEMOPS
        select VIDEOBUF2_CORE
        select VIDEOBUF2_MEMOPS
 -      select DMA_SHARED_BUFFER
-+      select DMA_SHARED_BUFFER if !BACKPORT_KERNEL_3_5
++      select DMA_SHARED_BUFFER if !KERNEL_3_5
  
  config VIDEOBUF2_VMALLOC
        tristate
        select VIDEOBUF2_CORE
        select VIDEOBUF2_MEMOPS
 -      select DMA_SHARED_BUFFER
-+      select DMA_SHARED_BUFFER if !BACKPORT_KERNEL_3_5
++      select DMA_SHARED_BUFFER if !KERNEL_3_5
  
  config VIDEOBUF2_DMA_SG
        tristate