Corrected patch, closes #326
authorFlorian Fainelli <florian@openwrt.org>
Sat, 25 Feb 2006 23:20:09 +0000 (23:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 25 Feb 2006 23:20:09 +0000 (23:20 +0000)
SVN-Revision: 3273

openwrt/package/sablevm-classpath/patches/100-fastjar.patch

index a3e924f7526c806a29f3c2fe2d1dd4e83b03b8d9..89b2a179c3bd61e7e2002a35b6b447dc97181871 100644 (file)
@@ -1,42 +1,42 @@
-diff -urN sablevm-classpath-1.11.3.orig/lib/Makefile.am sablevm-classpath-1.11.3/lib/Makefile.am
---- sablevm-classpath-1.11.3.orig/lib/Makefile.am       2005-03-24 15:58:58.000000000 -0500
-+++ sablevm-classpath-1.11.3/lib/Makefile.am    2005-12-05 23:38:23.208240037 -0500
+diff -urN sablevm-classpath-1.11.3.orig/lib/Makefile.am sablevm-classpath-1.11.3/lib/Makefile.am
+--- sablevm-classpath-1.11.3.orig/lib/Makefile.am      2005-03-24 21:58:58.000000000 +0100
++++ sablevm-classpath-1.11.3/lib/Makefile.am   2006-02-25 22:39:30.355625968 +0100
 @@ -93,7 +93,7 @@
  
  libclasspath.jar: classes compile-classes
-        if test "x$(FASTJAR)" != "x"; then \
--           $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf libclasspath.jar gnu java javax org > /dev/null; \
-+           $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) libclasspath.jar gnu java javax org > /dev/null; \
-        elif test "x$(ZIP)" != "x"; then \
-            $(ZIP) $(COMPRESSION_FLAGS) -r -D libclasspath.jar gnu java javax org > /dev/null; fi
+       if test "x$(FASTJAR)" != "x"; then \
+-          $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf libclasspath.jar gnu java javax org > /dev/null; \
++          $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) -Mcf libclasspath.jar gnu java javax org > /dev/null; \
+       elif test "x$(ZIP)" != "x"; then \
+           $(ZIP) $(COMPRESSION_FLAGS) -r -D libclasspath.jar gnu java javax org > /dev/null; fi
  
 @@ -112,7 +112,7 @@
-            cp -f $(top_srcdir)/resource/$$p resources_tmp/$$p; \
-        done
-        if test x"$(FASTJAR)" != "x"; then cd resources_tmp && \
--           $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf ../resources.jar gnu java javax org > /dev/null; \
-+           $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) ../resources.jar gnu java javax org > /dev/null; \
-        elif test x"$(ZIP)" != "x"; then cd resources_tmp && \
-            $(ZIP) $(COMPRESSION_FLAGS) -r -D ../resources.jar gnu java javax org > /dev/null; fi
-        rm -rf resources_tmp
+           cp -f $(top_srcdir)/resource/$$p resources_tmp/$$p; \
+       done
+       if test x"$(FASTJAR)" != "x"; then cd resources_tmp && \
+-          $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf ../resources.jar gnu java javax org > /dev/null; \
++          $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) -Mcf ../resources.jar gnu java javax org > /dev/null; \
+       elif test x"$(ZIP)" != "x"; then cd resources_tmp && \
+           $(ZIP) $(COMPRESSION_FLAGS) -r -D ../resources.jar gnu java javax org > /dev/null; fi
+       rm -rf resources_tmp
 diff -urN sablevm-classpath-1.11.3.orig/lib/Makefile.in sablevm-classpath-1.11.3/lib/Makefile.in
---- sablevm-classpath-1.11.3.orig/lib/Makefile.in       2005-03-24 16:01:29.000000000 -0500
-+++ sablevm-classpath-1.11.3/lib/Makefile.in    2005-12-05 23:38:03.514467812 -0500
+--- sablevm-classpath-1.11.3.orig/lib/Makefile.in      2005-03-24 22:01:29.000000000 +0100
++++ sablevm-classpath-1.11.3/lib/Makefile.in   2006-02-25 22:39:55.545796480 +0100
 @@ -501,7 +501,7 @@
  
  libclasspath.jar: classes compile-classes
-        if test "x$(FASTJAR)" != "x"; then \
--           $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf libclasspath.jar gnu java javax org > /dev/null; \
-+           $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) libclasspath.jar gnu java javax org > /dev/null; \
-        elif test "x$(ZIP)" != "x"; then \
-            $(ZIP) $(COMPRESSION_FLAGS) -r -D libclasspath.jar gnu java javax org > /dev/null; fi
+       if test "x$(FASTJAR)" != "x"; then \
+-          $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf libclasspath.jar gnu java javax org > /dev/null; \
++          $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) -Mcf libclasspath.jar gnu java javax org > /dev/null; \
+       elif test "x$(ZIP)" != "x"; then \
+           $(ZIP) $(COMPRESSION_FLAGS) -r -D libclasspath.jar gnu java javax org > /dev/null; fi
  
 @@ -520,7 +520,7 @@
-            cp -f $(top_srcdir)/resource/$$p resources_tmp/$$p; \
-        done
-        if test x"$(FASTJAR)" != "x"; then cd resources_tmp && \
--           $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf ../resources.jar gnu java javax org > /dev/null; \
-+           $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) ../resources.jar gnu java javax org > /dev/null; \
-        elif test x"$(ZIP)" != "x"; then cd resources_tmp && \
-            $(ZIP) $(COMPRESSION_FLAGS) -r -D ../resources.jar gnu java javax org > /dev/null; fi
-        rm -rf resources_tmp
\ No newline at end of file
+           cp -f $(top_srcdir)/resource/$$p resources_tmp/$$p; \
+       done
+       if test x"$(FASTJAR)" != "x"; then cd resources_tmp && \
+-          $(FASTJAR) $(COMPRESSION_FLAGS) -Mcf ../resources.jar gnu java javax org > /dev/null; \
++          $(FASTJAR) -Mcf$(COMPRESSION_FLAGS) -Mcf ../resources.jar gnu java javax org > /dev/null; \
+       elif test x"$(ZIP)" != "x"; then cd resources_tmp && \
+           $(ZIP) $(COMPRESSION_FLAGS) -r -D ../resources.jar gnu java javax org > /dev/null; fi
+       rm -rf resources_tmp