projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
28665d5
)
host-build: add HOST_MAKE_FLAGS similar to package MAKE_FLAGS
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 22 Sep 2012 20:10:28 +0000
(20:10 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 22 Sep 2012 20:10:28 +0000
(20:10 +0000)
SVN-Revision: 33509
include/host-build.mk
patch
|
blob
|
history
diff --git
a/include/host-build.mk
b/include/host-build.mk
index e011c1548011f84d18178fff94fece011e762d23..66795c8e1082c848a941dc09c87abd113a7e1387 100644
(file)
--- a/
include/host-build.mk
+++ b/
include/host-build.mk
@@
-69,6
+69,8
@@
HOST_CONFIGURE_ARGS = \
--localstatedir=$(STAGING_DIR_HOST)/var \
--sbindir=$(STAGING_DIR_HOST)/bin
+HOST_MAKE_FLAGS =
+
HOST_CONFIGURE_CMD = ./configure
ifneq ($(HOST_OS),Darwin)
@@
-95,7
+97,9
@@
define Host/Configure
endef
define Host/Compile/Default
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) $(1)
+ $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
+ $(HOST_MAKE_FLAGS) \
+ $(1)
endef
define Host/Compile