projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1e14f01
)
u-boot.mk: add support for overriding DEFAULT
author
Felix Fietkau
<nbd@nbd.name>
Wed, 25 Jan 2017 06:33:41 +0000
(07:33 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Wed, 25 Jan 2017 06:48:43 +0000
(07:48 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/u-boot.mk
patch
|
blob
|
history
diff --git
a/include/u-boot.mk
b/include/u-boot.mk
index de629233525f0361ee1a16a0f8b8c5ddc87a6982..0c2865332631f03f7c7920701ce4e073af1e3c89 100644
(file)
--- a/
include/u-boot.mk
+++ b/
include/u-boot.mk
@@
-32,6
+32,7
@@
define U-Boot/Init
NAME:=
DEPENDS:=
HIDDEN:=
+ DEFAULT:=
VARIANT:=$(1)
UBOOT_CONFIG:=$(1)
UBOOT_IMAGE:=u-boot.bin
@@
-59,6
+60,7
@@
define Build/U-Boot/Target
$(patsubst %,|| $(patsubst TARGET_%,TARGET_DEVICE_%,$(TARGET_DEP))_DEVICE_%,$(BUILD_DEVICES)))
endif
endif
+ $(if $(DEFAULT),DEFAULT:=$(DEFAULT))
URL:=http://www.denx.de/wiki/U-Boot
endef