compat-wirless: prefix release files with dot
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 4 May 2012 22:35:27 +0000 (15:35 -0700)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 4 May 2012 22:38:43 +0000 (15:38 -0700)
This prefixes these files with a dot:

compat_base_tree -->         .compat_base_tree
compat_base_tree_version --> .compat_base_tree_version
compat_version -->           .compat_version

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
.gitignore
Makefile
enable-older-kernels/enable-2.6.21.patch
enable-older-kernels/enable-2.6.22.patch
enable-older-kernels/enable-2.6.23.patch
scripts/admin-clean.sh
scripts/admin-update.sh
scripts/driver-select
scripts/gen-compat-autoconf.sh
scripts/refresh-compat

index 3e93d8959fb76ece6b3a08cd2f567070e564feea..b615253b56d1b48db9416c681a158be46feada7e 100644 (file)
@@ -11,9 +11,9 @@ Module.symvers
 module.order
 .pc
 code-metrics.txt
-compat_base_tree
-compat_base_tree_version
-compat_version
+.compat_base_tree
+.compat_base_tree_version
+.compat_version
 .compat_autoconf_compat-*
 .config
 .config.mk_md5sum.txt
index f2adff25a6476e79b873d344757f9b4de5d49982..49cbb59e08d3bff18b6851b0e2577ae2a3263b7a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -55,10 +55,10 @@ $(error "The path to this compat-wireless directory has spaces in it." \
 endif
 
 export CFLAGS += \
-        -DCOMPAT_BASE_TREE="\"$(shell cat $(PWD)/compat_base_tree)\"" \
-        -DCOMPAT_BASE_TREE_VERSION="\"$(shell cat $(PWD)/compat_base_tree_version)\"" \
+        -DCOMPAT_BASE_TREE="\"$(shell cat $(PWD)/.compat_base_tree)\"" \
+        -DCOMPAT_BASE_TREE_VERSION="\"$(shell cat $(PWD)/.compat_base_tree_version)\"" \
         -DCOMPAT_PROJECT="\"Compat-wireless\"" \
-        -DCOMPAT_VERSION="\"$(shell cat $(PWD)/compat_version)\""
+        -DCOMPAT_VERSION="\"$(shell cat $(PWD)/.compat_version)\""
 
 # These exported as they are used by the scripts
 # to check config and compat autoconf
@@ -66,7 +66,7 @@ export COMPAT_CONFIG_CW=$(PWD)/config.mk
 export COMPAT_CONFIG=$(PWD)/.config
 export CONFIG_CHECK=$(PWD)/.config.mk_md5sum.txt
 export COMPAT_AUTOCONF=include/linux/compat_autoconf.h
-export CREL=$(shell cat $(PWD)/compat_version)
+export CREL=$(shell cat $(PWD)/.compat_version)
 export CREL_PRE:=.compat_autoconf_
 export CREL_CHECK:=$(PWD)/$(CREL_PRE)$(CREL)
 
index 44a1bb25b7d8616f909120dcd40284b1ea3f4e65..593d9ddd790f6badd985dee55d5be05fb3cbfb94 100644 (file)
@@ -21,6 +21,6 @@
  # Update this if you are adding support for older kernels.
 -OLDEST_KERNEL_SUPPORTED="2.6.24"
 +OLDEST_KERNEL_SUPPORTED="2.6.21"
- COMPAT_RELEASE="compat_version"
- KERNEL_RELEASE="compat_base_tree_version"
+ COMPAT_RELEASE=".compat_version"
+ KERNEL_RELEASE=".compat_base_tree_version"
  MULT_DEP_FILE=".compat_pivot_dep"
index 127382499e3ef9087116e62425bfa5a58d3b6d97..86b35d60a6213490711320d420d4b570cd863701 100644 (file)
@@ -21,6 +21,6 @@
  # Update this if you are adding support for older kernels.
 -OLDEST_KERNEL_SUPPORTED="2.6.24"
 +OLDEST_KERNEL_SUPPORTED="2.6.22"
- COMPAT_RELEASE="compat_version"
- KERNEL_RELEASE="compat_base_tree_version"
+ COMPAT_RELEASE=".compat_version"
+ KERNEL_RELEASE=".compat_base_tree_version"
  MULT_DEP_FILE=".compat_pivot_dep"
index 7a958428a32eb0c0f22c01edc4a9f6f3808c93b6..82ba243f09b35613e09f6af6b43694691cebda1a 100644 (file)
@@ -21,6 +21,6 @@
  # Update this if you are adding support for older kernels.
 -OLDEST_KERNEL_SUPPORTED="2.6.24"
 +OLDEST_KERNEL_SUPPORTED="2.6.23"
- COMPAT_RELEASE="compat_version"
- KERNEL_RELEASE="compat_base_tree_version"
+ COMPAT_RELEASE=".compat_version"
+ KERNEL_RELEASE=".compat_base_tree_version"
  MULT_DEP_FILE=".compat_pivot_dep"
index 81398f2a28f7f5504d939acd4ef966840d62f8bd..4f8c4d1d52c3a74d3da8436a0b060f4f2968bdad 100755 (executable)
@@ -8,8 +8,8 @@ rm -rf include
 rm -rf compat
 rm -rf udev
 rm -f master-tag
-rm -f compat_base_tree
-rm -f compat_base_tree_version
-rm -f compat_version
+rm -f .compat_base_tree
+rm -f .compat_base_tree_version
+rm -f .compat_version
 rm -f code-metrics.txt
 echo "Cleaned wireless-bt-compat-2.6"
index fd1fa8782d5a266f273a7f3edc0cfbece4db5ec2..362f9c4ef04578d50cb2aa1d58480494e1a5894b 100755 (executable)
@@ -602,25 +602,25 @@ echo -e "Origin remote URL: ${CYAN}${GIT_REMOTE_URL}${NORMAL}"
 cd $DIR
 if [ -d ./.git ]; then
        if [[ ${POSTFIX_RELEASE_TAG} != "" ]]; then
-               echo -e "$(git describe)-${POSTFIX_RELEASE_TAG}" > compat_version
+               echo -e "$(git describe)-${POSTFIX_RELEASE_TAG}" > .compat_version
        else
-               echo -e "$(git describe)" > compat_version
+               echo -e "$(git describe)" > .compat_version
        fi
 
        cd $GIT_TREE
        TREE_NAME=${GIT_REMOTE_URL##*/}
 
-       echo $TREE_NAME > $DIR/compat_base_tree
-       echo $GIT_DESCRIBE > $DIR/compat_base_tree_version
+       echo $TREE_NAME > $DIR/.compat_base_tree
+       echo $GIT_DESCRIBE > $DIR/.compat_base_tree_version
 
        case $TREE_NAME in
        "wireless-testing.git") # John's wireless-testing
-               # We override the compat_base_tree_version for wireless-testing
+               # We override the .compat_base_tree_version for wireless-testing
                # as john keeps the Linus' tags and does not write a tag for his
                # tree himself so git describe would yield a v2.6.3x.y-etc but
                # what is more useful is just the wireless-testing master tag
                MASTER_TAG=$(git tag -l| grep master | tail -1)
-               echo $MASTER_TAG > $DIR/compat_base_tree_version
+               echo $MASTER_TAG > $DIR/.compat_base_tree_version
                echo -e "This is a ${RED}wireless-testing.git${NORMAL} compat-wireless release"
                ;;
        "linux-next.git") # The linux-next integration testing tree
@@ -639,9 +639,9 @@ if [ -d ./.git ]; then
        esac
 
        cd $DIR
-       echo -e "\nBase tree: ${GREEN}$(cat compat_base_tree)${NORMAL}" >> $CODE_METRICS
-       echo -e "Base tree version: ${PURPLE}$(cat compat_base_tree_version)${NORMAL}" >> $CODE_METRICS
-       echo -e "compat-wireless release: ${YELLOW}$(cat compat_version)${NORMAL}" >> $CODE_METRICS
+       echo -e "\nBase tree: ${GREEN}$(cat .compat_base_tree)${NORMAL}" >> $CODE_METRICS
+       echo -e "Base tree version: ${PURPLE}$(cat .compat_base_tree_version)${NORMAL}" >> $CODE_METRICS
+       echo -e "compat-wireless release: ${YELLOW}$(cat .compat_version)${NORMAL}" >> $CODE_METRICS
 
 fi
 
index c8aff636cde53a6652be643be18e407f1c255f5f..3d164679f8c029a6f0f899ec99bae042fff8f511 100755 (executable)
@@ -278,7 +278,7 @@ if [ $# -ne 1 ]; then
        exit
 fi
 
-if [ ! -f compat_version ]; then
+if [ ! -f .compat_version ]; then
        echo "Must run $0 from the compat-wireless top level directory"
        exit
 fi
index c7bdd38d0b1d5aa3011b25a863e24152491ea8e1..1b82184ed14cf54d0e4a8584e4506fdee9212341 100755 (executable)
@@ -12,8 +12,8 @@
 # This indicates which is the oldest kernel we support
 # Update this if you are adding support for older kernels.
 OLDEST_KERNEL_SUPPORTED="2.6.24"
-COMPAT_RELEASE="compat_version"
-KERNEL_RELEASE="compat_base_tree_version"
+COMPAT_RELEASE=".compat_version"
+KERNEL_RELEASE=".compat_base_tree_version"
 MULT_DEP_FILE=".compat_pivot_dep"
 
 if [ $# -ne 2 ]; then
index d4c44c8739867ee84c3c535a4a9a91704b51d44f..2f00282b28f4ee19ea36a1c4d46d9c00a9d8aa67 100755 (executable)
@@ -11,9 +11,9 @@
 # udev/
 # include/
 # scripts/
-# compat_base_tree
-# compat_base_tree_version
-# compat_version
+# .compat_base_tree
+# .compat_base_tree_version
+# .compat_version
 # config.mk
 #
 # An example git tree for standalone development will be provided later.
@@ -52,9 +52,9 @@ COPY="$COPY scripts/compress_modules"
 COPY="$COPY scripts/gen-compat-autoconf.sh"
 COPY="$COPY scripts/modlib.sh"
 COPY="$COPY scripts/update-initramfs"
-COPY="$COPY compat_base_tree"
-COPY="$COPY compat_base_tree_version"
-COPY="$COPY compat_version"
+COPY="$COPY .compat_base_tree"
+COPY="$COPY .compat_base_tree_version"
+COPY="$COPY .compat_version"
 COPY="$COPY config.mk"
 COPY="$COPY $EXTRA_COPY"
 
@@ -89,10 +89,10 @@ rm -f .config
 
 cp -f ${COMPAT_SRC}/${REFRESH_LOCAL} ${REFRESH_TARGET}
 
-if [[ ! -f compat_base_tree_version ]]; then
+if [[ ! -f .compat_base_tree_version ]]; then
        echo -e "Failed at copying files over..."
        exit 1
 fi
 
 echo
-echo -e "Synched with ${CYAN}$(cat compat_version)${NORMAL}"
+echo -e "Synched with ${CYAN}$(cat .compat_version)${NORMAL}"