projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f3be1b4
)
build system: add support for download-time make hooks
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 30 Sep 2011 11:12:13 +0000
(11:12 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 30 Sep 2011 11:12:13 +0000
(11:12 +0000)
SVN-Revision: 28322
include/package.mk
patch
|
blob
|
history
diff --git
a/include/package.mk
b/include/package.mk
index 1c2c179cdaf1a728c8efc6f90871152f1bc620d3..cfb39dac8359c4e0c342a313b80513acea405fba 100644
(file)
--- a/
include/package.mk
+++ b/
include/package.mk
@@
-100,6
+100,11
@@
define Build/DefaultTargets
$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
$(call Build/Autoclean)
+ download:
+ $(foreach hook,$(Hooks/Download),
+ $(call $(hook))$(sep)
+ )
+
$(STAMP_PREPARED) : export PATH=$$(TARGET_PATH_PKG)
$(STAMP_PREPARED):
@-rm -rf $(PKG_BUILD_DIR)