qualcommax: ipq807x: add Netgear DEVICE_VARS
authorRobert Marko <robimarko@gmail.com>
Sat, 7 Dec 2024 21:08:18 +0000 (22:08 +0100)
committerRobert Marko <robimarko@gmail.com>
Sun, 8 Dec 2024 08:58:38 +0000 (09:58 +0100)
Add NETGEAR_BOARD_ID and NETGEAR_HW_ID to DEVICE_VARS as multiple devices
set them in their recipes, so without them being added to DEVICE_VARS then
simply the value from last recipe that gets evaluated is used and images
are generated with the wrong ID-s.

Link: https://github.com/openwrt/openwrt/pull/17203
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/qualcommax/image/ipq807x.mk

index 34fe92ed54c138ea2610d67394d481114c4edd26..ff6963405c61e90b356011a0d7fbf3e03c974f8f 100644 (file)
@@ -1,3 +1,5 @@
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
+
 define Build/asus-fake-ramdisk
        rm -rf $(KDIR)/tmp/fakerd
        dd if=/dev/zero bs=32 count=1 > $(KDIR)/tmp/fakerd