projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
661d970
)
make sure iw doesn't get compiled on older kernels
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 30 Nov 2007 11:33:31 +0000
(11:33 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 30 Nov 2007 11:33:31 +0000
(11:33 +0000)
SVN-Revision: 9639
package/iw/Makefile
patch
|
blob
|
history
diff --git
a/package/iw/Makefile
b/package/iw/Makefile
index 36361fb3177bdb9ed179410901a747de4e48663d..024dfde24e89f3d575b27042e68332bbbe77f366 100644
(file)
--- a/
package/iw/Makefile
+++ b/
package/iw/Makefile
@@
-38,9
+38,11
@@
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl -I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -lnl"
-define Package/iw/install
+ifneq ($(CONFIG_LINUX_2_6_23),)
+ define Package/iw/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/iw $(1)/usr/sbin/
-endef
+ endef
+endif
$(eval $(call BuildPackage,iw))