projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c981369
)
kernel: add ohci-platform.ko for 3.11+
author
John Crispin
<john@openwrt.org>
Mon, 25 Aug 2014 16:30:52 +0000
(16:30 +0000)
committer
John Crispin
<john@openwrt.org>
Mon, 25 Aug 2014 16:30:52 +0000
(16:30 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 42288
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 96c899a8dd8e27326d025c505175e7b9a422564f..0b5abdc3351e69afb4d14d57d95f770f2cffcb9a 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-331,7
+331,10
@@
define KernelPackage/usb-ohci
CONFIG_USB_OHCI_HCD_OMAP3=y \
CONFIG_USB_OHCI_HCD_PLATFORM=y
FILES:=$(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko
- AUTOLOAD:=$(call AutoLoad,50,ohci-hcd,1)
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.11.0)),1)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
+endif
+ AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
$(call AddDepends/usb)
endef