projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
10e3ea9
)
install readelf to STAGING_DIR_HOST (eglibc requires it, not all systems have it)
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 26 Jan 2009 04:54:25 +0000
(
04:54
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 26 Jan 2009 04:54:25 +0000
(
04:54
+0000)
SVN-Revision: 14196
toolchain/binutils/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/binutils/Makefile
b/toolchain/binutils/Makefile
index e6f60a846c293a06c0928579409eea2c7972370b..93d639220114b207f008eee72a7b1806388854e3 100644
(file)
--- a/
toolchain/binutils/Makefile
+++ b/
toolchain/binutils/Makefile
@@
-24,6
+24,7
@@
endif
PATCH_DIR:=./patches/$(PKG_VERSION)
+REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
@@
-62,6
+63,7
@@
endef
define Build/Install
$(MAKE) -C $(PKG_BUILD_DIR) install
+ $(CP) $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef
define Build/Clean