projects
/
openwrt
/
staging
/
jogo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
93d5629
)
kmod-bmp085: add dependency on !LINUX_3_18 !LINUX_4_1
author
Alexander Couzens
<lynxis@fe80.eu>
Wed, 29 Jun 2016 00:40:34 +0000
(
02:40
+0200)
committer
Alexander Couzens
<lynxis@fe80.eu>
Wed, 29 Jun 2016 00:46:48 +0000
(
02:46
+0200)
93d5629a
introduced a build failure on older platforms (<4.4)
because bmp085 is a boolean and not a tristate.
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index bc7fb7c02facdd9c7f8d580fcfb2a9f7f81e9d51..55fd455f0618e3c90ef5c97271f2dadd06c4091b 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-995,7
+995,7
@@
$(eval $(call KernelPackage,echo))
define KernelPackage/bmp085
SUBMENU:=$(OTHER_MENU)
TITLE:=BMP085/BMP18x pressure sensor
- DEPENDS:= +kmod-regmap
+ DEPENDS:= +kmod-regmap
@!LINUX_3_18 @!LINUX_4_1
KCONFIG:= CONFIG_BMP085
FILES:= $(LINUX_DIR)/drivers/misc/bmp085.ko
endef